Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Cannot Install Eclipse Oxygen(The install process for Eclipse Oxygen crashes when I run it)
Cannot Install Eclipse Oxygen [message #1784144] Thu, 22 March 2018 21:18 Go to next message
Jim Anderson is currently offline Jim AndersonFriend
Messages: 72
Registered: October 2014
Member
I'm work on a Linux PC running the Bunsenlabs Deuterium distribution.

I started running Eclipse Oxygen a month or two ago and things were more or less running for me. This work was in pure java. Then about 2 weeks ago, I started working on some JNI code. I installed the CDT plug-in. I never got the to point where I could debug both C and Java code in Eclipse, but I got close. I will return to that at some point in the future but the C code is working and I'm returning a pure Java environment. As soon as I started up Eclipse with Java, I started have problems with Eclipse, getting stack traces from Eclipse. The traces indicated the errors were in the Eclipse source code. I tried a number of things and I suspected that either my workspace or install had gotten corrupted.

Long story, short is that I finally decided to go back to ground zero and I removed the Eclipse installation and my workspace. I downloaded 'eclipse-inst-linux64.tar.gz' and used that to try to reinstall Eclipse. After untarring the file, I ran eclipse-inst (a few times) and each time I get the error log file that is attached.

Interestingly, the first error in the log:

Quote:
41 [2018-03-22 16:35:41] Collecting 5 artifacts from http://download.eclipse.org/technology/epp/packages/oxygen
42 [2018-03-22 16:35:41] An error was detected while performing the engine operation and the changes are being rolled back. See the log for details.
43 [2018-03-22 16:35:41] ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while collecting items to be installed
44 at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
45 at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:547)
46 at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:340)
47 at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:729)
48 at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3324)
49 at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3252)
50 at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3233)
51 at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3133)
52 at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.installPerform(SimpleVariablePage.java:1298)
53 at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.access$32(SimpleVariablePage.java:1166)
54 at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage$20.run(SimpleVariablePage.java:1111)
55 ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=_usr_share_java-oxygen_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.C ollect, operand=, action=).
56 ERROR: org.eclipse.equinox.p2.engine code=0 java.lang.NoClassDefFoundError: org/w3c/dom/ElementTraversal




is very similar to the errors that I was getting in Eclipse Oxygen before I deleted the old installation. In particular, lines 41, 43 and 56 appeared when Eclipse Oxygen crashed.

I plan to report the crash of the installer and Eclipse in a bug report, but for now I'm wondering if the error that class 'org/w3c/dom/ElementTraversal' was not found is a hint to someone.

Jim A.

Re: Cannot Install Eclipse Oxygen [message #1784170 is a reply to message #1784144] Fri, 23 March 2018 08:22 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29551
Registered: July 2009
Senior Member
Yes, as I mentioned in https://bugs.eclipse.org/bugs/show_bug.cgi?id=532790 it looks to my like a fundamental problem with the JDK/JRE not properly supported JAXP's XML parsing.
Previous Topic:Pydev F2 shortcut not working
Next Topic:eclipse and qml
Goto Forum:
  


Current Time: Tue Sep 25 10:06:16 GMT 2018

Powered by FUDForum. Page generated in 0.02660 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top