Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Papyrus 3.3 is available
Papyrus 3.3 is available [message #1784016] Wed, 21 March 2018 14:57 Go to next message
Patrick Tessier is currently offline Patrick TessierFriend
Messages: 229
Registered: July 2009
Location: Paris Saclay, France
Senior Member
Papyrus UML 3.3 is available at https://download.eclipse.org/releases/oxygen/ :
This version fix some problems, it contains:
- Layers integration
- Bug fixes on the model explorer
- Bug fixes on the sequence diagram
- Bug fixes about performance
You can have more detailled information, or know the list of fixed bugs on https://wiki.eclipse.org/Papyrus/NewAndNoteworthy/Oxygen

Papyrus Team
Re: Papyrus 3.3 is available [message #1784026 is a reply to message #1784016] Wed, 21 March 2018 17:00 Go to previous messageGo to next message
Carsten Pitz is currently offline Carsten PitzFriend
Messages: 137
Registered: May 2015
Location: Germany
Senior Member
A big "mercy bien" to the Papyrus team.
/pica
Re: Papyrus 3.3 is available [message #1786032 is a reply to message #1784026] Tue, 24 April 2018 11:56 Go to previous messageGo to next message
Hans Huckebein is currently offline Hans HuckebeinFriend
Messages: 15
Registered: January 2015
Junior Member
Hi there,
- under www.eclipse.org/papyrus/download.html it is still stated, that version 2.0 for Eclipse-Neon is the recommended download.
- the news-box on index page says that the release message for Version 3.3 was posted on Apr 03, 2017

I suppose this is not completely the current state. What should I choose for (somewhat stable) company use?
Thank you
Hans
Re: Papyrus 3.3 is available [message #1786164 is a reply to message #1786032] Thu, 26 April 2018 11:04 Go to previous messageGo to next message
Ansgar Radermacher is currently offline Ansgar RadermacherFriend
Messages: 159
Registered: March 2011
Location: Paris Saclay, France
Senior Member
Hi Hans,

you are right. We do not recommend any more to use Papyrus 2.x for Eclipse neon. We will correct the information on the download page soon. The recommended stable version is version 3.3.

Best regards

Ansgar
Re: Papyrus 3.3 is available [message #1786169 is a reply to message #1786164] Thu, 26 April 2018 12:26 Go to previous message
Benoit Maggi is currently offline Benoit MaggiFriend
Messages: 129
Registered: March 2013
Location: Bordeaux, France
Senior Member
Hi Hans,

Thanks for pointing that. We removed the "recommended" from the download section.
By default we recommend to use the latest release but depending on your context, you may prefer older versions or even working with the nightly build.

Regards,
Benoit
Previous Topic:How to re-arrange automatically component elements and/or copy-paste arrangement from components
Next Topic:How to Symbolically execute state machine in Eclipse Papyrus and Moka extension?
Goto Forum:
  


Current Time: Tue Sep 18 17:44:24 GMT 2018

Powered by FUDForum. Page generated in 0.02458 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top