Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mosquitto » Mosquitto on Raspberry PI3 (mosquito systemctl start mosquitto.service fails while cmd start works)
Mosquitto on Raspberry PI3 [message #1783163] Thu, 08 March 2018 16:01
Juergen Schubert is currently offline Juergen SchubertFriend
Messages: 1
Registered: March 2018
Junior Member
Folks,

when I run a systemctl start mosquitto.service
or better a
# sudo systemctl start mosquitto.service
and a
# sudo systemctl status mosquitto.service
‚óŹ mosquitto.service - Mosquitto MQTT Broker daemon
Loaded: loaded (/etc/systemd/system/mosquitto.service; enabled; vendor preset: enabled)
Active: inactive (dead) since Thu 2018-03-08 16:57:03 CET; 43s ago
Process: 1981 ExecStart=/usr/local/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf -d (code=exited, status=0/SUCCESS)
Main PID: 1981 (code=exited, status=0/SUCCESS)

Mar 08 16:57:02 nodered-pi systemd[1]: Started Mosquitto MQTT Broker daemon.

when I do a
#/usr/local/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf
1520524693: mosquitto version 1.4.14 (build date 2017-12-27 12:22:37+0100) starting
1520524693: Config loaded from /etc/mosquitto/mosquitto.conf.
1520524693: Opening ipv4 listen socket on port 1883.
1520524694: New connection from 192.168.1.141 on port 1883.
1520524694: New client connected from 192.168.1.141 as ESP8266-IOT-DH22 (c1, k15, u'mosquittopi').

Things are working fine. So I don't get it why the -d causes to fail the startup

cat /etc/systemd/system/mosquitto.service
[Unit]
Description=Mosquitto MQTT Broker daemon
ConditionPathExists=/etc/mosquitto/mosquitto.conf
Wants=multi-user.target
After=multi-user.target
Requires=network.target

[Service]
Type=simple
ExecStart=/usr/local/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf -d
ExecReload=/bin/kill -HUP $MAINPID
User=mosquitto
PIDFile=/run/mosquitto.pid
Restart=on-failure
RestartSec=10

[Install]
WantedBy=multi-user.target
Previous Topic:Mosquitto: New installation on Server2012R2 wont run
Next Topic:TLS SSL Socket error on client , disconnecting
Goto Forum:
  


Current Time: Fri Sep 21 15:56:48 GMT 2018

Powered by FUDForum. Page generated in 0.02484 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top