Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Nebula GridItem.setColumnSpan display problem
Nebula GridItem.setColumnSpan display problem [message #1783001] Tue, 06 March 2018 10:46 Go to next message
Nin Pa is currently offline Nin PaFriend
Messages: 29
Registered: September 2013
Junior Member
Hello everybody,

got another problem using nebulas grid.

When I am using GridItem.setColumnSpan(index, span) it works well. But in large tables, there is an display problem. So the columns span is only shown when i scroll down the table and the mouse pointer hovers the line, where the span is.

Trying to show it with screenshots:
1) Before mouse hovers the item
index.php/fa/32227/0/

2) After mouse hovered the item
index.php/fa/32228/0/

Anyone an idea, how to fix this behaviour?
Best regards!
  • Attachment: Before.JPG
    (Size: 9.90KB, Downloaded 64 times)
  • Attachment: After.JPG
    (Size: 9.51KB, Downloaded 68 times)

[Updated on: Tue, 06 March 2018 10:47]

Report message to a moderator

Re: Nebula GridItem.setColumnSpan display problem [message #1783008 is a reply to message #1783001] Tue, 06 March 2018 12:40 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2279
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
is it reproducible in all browsers - Chrome, Firefox, IE, Edge? Do you have a custom theme? Please open a bugzilla and attach a project to demonstrate the problem.
Regards,
Ivan
Re: Nebula GridItem.setColumnSpan display problem [message #1783238 is a reply to message #1783008] Fri, 09 March 2018 13:30 Go to previous message
Nin Pa is currently offline Nin PaFriend
Messages: 29
Registered: September 2013
Junior Member
It is the same in the RAP Examples Demo:
Before hovering:
index.php/fa/32264/0/
After hovering:
index.php/fa/32265/0/

I will create a bugzilla.
  • Attachment: Before.JPG
    (Size: 34.32KB, Downloaded 50 times)
  • Attachment: After.JPG
    (Size: 33.81KB, Downloaded 43 times)
Previous Topic:Nebula GridItem.setForeground not working
Next Topic:ExpandableComposite Twistie style not rendering
Goto Forum:
  


Current Time: Mon Jun 18 11:58:46 GMT 2018

Powered by FUDForum. Page generated in 0.02434 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top