Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse started over X remote comes up minimized
Eclipse started over X remote comes up minimized [message #1782909] Sun, 04 March 2018 21:18 Go to next message
Steinar Bang is currently offline Steinar BangFriend
Messages: 108
Registered: July 2009
Senior Member
I'm trying to start eclipse oxygen on a debian 9 "stretch" computer, displaying on a remote X display in Cygwin X on a Windows 10 computer.

The banner displays normally, but the eclipse IDE window comes up squashed to a point, and there is no way to expand it.

I there a way to force eclipse to come up maximized on startup?

Is there a way to avoid having eclipse squashed up on a remote display?

When eclipse is started from the gnome desktop it comes up normally.

Thanks!


- Steinar
Re: Eclipse started over X remote comes up minimized [message #1783024 is a reply to message #1782909] Tue, 06 March 2018 17:43 Go to previous messageGo to next message
Steinar Bang is currently offline Steinar BangFriend
Messages: 108
Registered: July 2009
Senior Member
This is probably something releated to the cygwin X server and/or the way I'm running it: no desktop (X windows appearing as native windows windows (er...)).

I did an experiment where I did "ssh -Y " from the a terminal on the gnome (actually "mate") desktop on the debian computer to a different computer and then a new "ssh -Y " back to the debian computer and then started eclipse through two ssh X forwarding connections, and that started normally and displayed normally.
Re: Eclipse started over X remote comes up minimized [message #1783276 is a reply to message #1783024] Sat, 10 March 2018 11:22 Go to previous message
Steinar Bang is currently offline Steinar BangFriend
Messages: 108
Registered: July 2009
Senior Member
There is a workaround: add "-extension RANDR" to "Additional parameters for X server" in the "Extra settings" window of the XLaunch wizard, and then eclipse oxygen started on a remote computer, will display fine on the cygwin X rootless display.

See: https://sourceware.org/ml/cygwin/2018-03/msg00126.html

It's likely that future releases of cygwin X will not have this issue, the snapshot build mentioned at the end of this message worked for me, without setting "-extension RANDR": https://sourceware.org/ml/cygwin/2018-03/msg00138.html

[Updated on: Sat, 10 March 2018 11:24]

Report message to a moderator

Previous Topic:Setup an environment to debug and compile the Eclipse platform
Next Topic:Verify installation of Eclipse and Jars for Selenium
Goto Forum:
  


Current Time: Tue Jun 19 11:01:53 GMT 2018

Powered by FUDForum. Page generated in 0.02661 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top