Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » JNA .jar files with Eclipse(Launcher can't find class files at run time)
JNA .jar files with Eclipse [message #1782524] Mon, 26 February 2018 00:44
Jeffrey Cummings is currently offline Jeffrey CummingsFriend
Messages: 2
Registered: June 2017
Junior Member
I've been asked to assume responsibility for a Java application which uses the Eclipse plugin technology with which I have no experience. The person who developed this app has retired and is not available for consultation. My problem is that I have tried various combinations of Eclipse versions, JNA versions, and locations for the JNA .jar files with no success. The app code all compiles with no complaints, i.e., Eclipse can access the JNA .class files as needed while compiling. But at run time, the Eclipse launcher produces mysterious (to me) error messages which boil down to the claim that it can't find the JNA .class files at run time. I'm currently focused on Eclipse version 4.5.2 (Mars) and have tried JNA versions 3.0.0 and 4.0.0. If there is anyone on this forum who has experience in this area, I would welcome some help.
Previous Topic:Program keeps terminating
Next Topic:Editor windows relocating themselves
Goto Forum:
  


Current Time: Sat Jun 23 12:32:39 GMT 2018

Powered by FUDForum. Page generated in 0.02543 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top