Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Installation help needed on Mars
Installation help needed on Mars [message #1782163] Mon, 19 February 2018 17:48 Go to next message
Matthijs Rademakers is currently offline Matthijs RademakersFriend
Messages: 2
Registered: February 2018
Junior Member
Hello,

I am a very infrequent user of Eclipse and new to the topic of UML modelling.
Eclipse: Version: Mars.2 Release (4.5.2)
Build id: 20160218-0600

When it comes to installing Papyrus, my guess is that I should stick to the MARS version of Papyrus. This is what my installation dialogue looks like:
index.php/fa/32133/0/

After pressing next, the screen shows me a warning "Cannot perform operation. Computing alternate solutions..." and when I press "Show original error and build my own solution" my screen looks like this:
index.php/fa/32134/0/.

How do I adress this problem and is this kind of behavior expected? I would have hoped for the Eclipse installer to solve these dependencies.

Thanks for helping out/explaining !
Re: Installation help needed on Mars [message #1782275 is a reply to message #1782163] Wed, 21 February 2018 08:12 Go to previous messageGo to next message
Johan Van Noten is currently offline Johan Van NotenFriend
Messages: 87
Registered: July 2009
Member
Dear Matthijs,

Thanks for using Papyrus!

I'm not sure whether you depend on the Eclipse Mars version for other projects. If not, I would propose to take the Oxigen version.
You can find it here: https://www.eclipse.org/papyrus/download.html
Scroll down to the RCP version and you will have a all-in-one installer of Papyrus' latest version.

In case you depend on Mars for other reasons, you can still complete the process as you were doing. You were only a bit too eager to select all components. Most people only need to take the "Papyrus" package, not the other ones such as "Qompass".

If you keep having issues, please post back.

Best regards,
Johan

Re: Installation help needed on Mars [message #1782301 is a reply to message #1782275] Wed, 21 February 2018 13:55 Go to previous message
Matthijs Rademakers is currently offline Matthijs RademakersFriend
Messages: 2
Registered: February 2018
Junior Member
Johan, thanks for your guidance! I managed to successfully install the Oxygen Version of Eclipse and then added Papyrus Oxygen using using the "Install Software feature" from the Help Menu. This time it worked!

[Updated on: Wed, 21 February 2018 13:57]

Report message to a moderator

Previous Topic:Generalization problem
Next Topic:Default Naming Strategies changes in Papyrus.
Goto Forum:
  


Current Time: Fri Sep 21 10:28:18 GMT 2018

Powered by FUDForum. Page generated in 0.01579 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top