Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Installation papyrus doubt(Its not clear enough the steps to install papyrus)
Installation papyrus doubt [message #1782033] Fri, 16 February 2018 10:01 Go to next message
Eduardo Gutierrez is currently offline Eduardo GutierrezFriend
Messages: 28
Registered: December 2017
Junior Member
Well i have Eclipse Oxygen and i have installed Papyrus Software Designer 1.0.5.

I need also to generate code( Java) from the UML diagram class.

So i dont need to install any plugin ?
Papyrus plugin is only from older versions of Eclipse that doesnt support marketplace ? Or i need to install both, the designer and plugins ?

From now i have installed both ( papyrus plugin and Papyrus Software Designer from marketplace) but i think im doing double work, or perhaps something wrong.

As i work in Java i have to import the Java Primitives from profile and registered packages in every class diagram.

I also would suggest to add more java types like strings.

Thanks in advance

[Updated on: Mon, 19 February 2018 10:32]

Report message to a moderator

Re: Installation papyrus doubt [message #1782185 is a reply to message #1782033] Tue, 20 February 2018 10:01 Go to previous messageGo to next message
Quentin Le Menez is currently offline Quentin Le MenezFriend
Messages: 25
Registered: September 2014
Location: Paris Saclay, France
Junior Member
Hi Eduardo,

I would say that when you install designer from the market place its dependencies are automatically (if the available update sites contain them) fetched. You therefore indeed do not need to install Papyrus on top of it all ;)
However you won't have access to all of Papyrus' functionalities if the project itself do not need it all to work.

HTH,
Quentin
Re: Installation papyrus doubt [message #1782189 is a reply to message #1782185] Tue, 20 February 2018 10:19 Go to previous messageGo to next message
Eduardo Gutierrez is currently offline Eduardo GutierrezFriend
Messages: 28
Registered: December 2017
Junior Member
Thanks for your answer, then id suggest that in installation process, would be something like:

Eclipse releases previous to ..... ( Oxygen ??) : Then install plugin and version X ( Oxygen) : install PDi component from marketplace.
Also would be great to have an option o package with all Papyrus related ( ex: Java Code, Java Primitives, Java Profile etc...) and dont need to follow additional steps. The same to other languages like C++, Sql....

Also a last question is: if you use UML you dont need to install SysML ?? Or it has some additional Features ???

Thanks again
Re: Installation papyrus doubt [message #1782199 is a reply to message #1782189] Tue, 20 February 2018 11:32 Go to previous message
Carsten Pitz is currently offline Carsten PitzFriend
Messages: 126
Registered: May 2015
Location: Germany
Senior Member
Hi Eduardo,

the compatibity information is part of the package meta data. As a result the package manager does all the magic for you. I really like that service ;-)

/pica
Previous Topic:Palette definition extention
Next Topic:Generalization problem
Goto Forum:
  


Current Time: Mon Jun 25 02:47:35 GMT 2018

Powered by FUDForum. Page generated in 0.01310 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top