Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » My First Maven/Tycho Failure: Sirius 5.1.0 repo missing?
My First Maven/Tycho Failure: Sirius 5.1.0 repo missing? [message #1781386] Tue, 06 February 2018 16:13 Go to next message
Brandon Lewis is currently offline Brandon LewisFriend
Messages: 175
Registered: May 2012
Senior Member
I've recently migrated the build process for my RCP apps to Maven/Tycho. And even more recently, I've included Sirius in my RCP app.

My target for Maven/Tycho included the following update site:

<repository location="http://download.eclipse.org/sirius/updates/releases/5.1.0/neon"/>

Coincidentally, it appears 5.1.1 was just released.

Was the update site for 5.1.0 destroyed or no longer maintained? Or was the Maven repo destroyed in the process? My Eclipse target still seems to resolve while pointing to the update site. But my Jenkins Maven build is crashing on the Sirius 5.1.0 repo.

Asking because I don't fully understand how these things are supposed to be managed. I assumed that 5.1.0 would still be valid.

From my side, Tycho is handling going between my Eclipse target and Maven. I don't fully understand how that works.

[Updated on: Tue, 06 February 2018 16:31]

Report message to a moderator

Re: My First Maven/Tycho Failure: Sirius 5.1.0 repo missing? [message #1781399 is a reply to message #1781386] Tue, 06 February 2018 18:22 Go to previous messageGo to next message
Brandon Lewis is currently offline Brandon LewisFriend
Messages: 175
Registered: May 2012
Senior Member
Actually, if I re-load my target in Eclipse, the update site is complaining it's broken even before I get to the Maven/Tycho build:

location http://download.eclipse.org/sirius/updates/releases/5.1.0/neon: Artifact not found: http://download.eclipse.org/sirius/updates/releases/5.1.0/neon/content.xml.xz.
Re: My First Maven/Tycho Failure: Sirius 5.1.0 repo missing? [message #1781419 is a reply to message #1781399] Wed, 07 February 2018 07:59 Go to previous message
Pierre-Charles David is currently offline Pierre-Charles DavidFriend
Messages: 522
Registered: July 2009
Senior Member
Hi.

This is a caching issue. After the release of 5.1.1 I moved all the non-current releases of each stream to archive.download.org (to make room on the main server and its mirrors). I've put redirects in place from download.eclipse.org to make this as transparent as possible, but it's not perfect.
Concretely, http://download.eclipse.org/sirius/updates/releases/5.1.0/neon is still a valid repo, but its internal structure has changed: it is now a "composite" p2 repository with a single entry that points to http://archive.eclipse.org/sirius/updates/releases/5.1.0/neon, and the content.xml.xz only exists on the archive.eclipse.org location now.

You can either clear your caches, point directly to http://archive.eclipse.org/sirius/updates/releases/5.1.0/neon, or use the newly released 5.1.1 (which for now is still physically on download.eclipse.org).

Regards,


Pierre-Charles David - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Previous Topic:Disable default context menu and properties
Next Topic:Trigger on action Copy/Paste
Goto Forum:
  


Current Time: Sat Apr 04 10:14:02 GMT 2020

Powered by FUDForum. Page generated in 0.02124 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top