Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Android requires compiler compliance level 5.0 or 6.0. Found '1.8' instead(Developing Android application in Eclipse w/ Java 8)
Android requires compiler compliance level 5.0 or 6.0. Found '1.8' instead [message #1781246] Sun, 04 February 2018 21:56
Alessandro Donnini is currently offline Alessandro DonniniFriend
Messages: 2
Registered: December 2015
Junior Member
Hello,

I am developing an Android application using Eclipse.

Eclipse IDE for Java Developers
Version: Oxygen.2 Release (4.7.2)
Build id: 20171218-0600
OS: Linux, v.4.9.0-4-amd64, x86_64 / gtk 3.22.11, WebKit 2.16.6

In Window/Preferences:

Java/Complier
Java compliance level ----> 1.8

Installed JREs - java-8-openjdk-amd64

When I set in my project properties the Java compiler entry to 1.8, and attempt to build the project, the build fails with the following message:

"Android requires compiler compliance level 5.0 or 6.0. Found '1.8' instead. Please use Android Tools > Fix Project Properties."

This happens regardless of the Android settings in project properties.

When I build the same project using Android Studio, there is no problem with the build (but I have other issues).

I would appreciate feedback about this, and ideas about a possible resolution. I need to use Java 8.

Thanks in advance,

Alex Donnini
Previous Topic:trouble upgrading oxygen, rolls back to neon 3?
Next Topic: JavaScript editor
Goto Forum:
  


Current Time: Tue May 22 04:38:33 GMT 2018

Powered by FUDForum. Page generated in 0.02539 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top