Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Eclipse is not debugging my web app
Eclipse is not debugging my web app [message #1781146] Fri, 02 February 2018 02:33
Karen Goh is currently offline Karen GohFriend
Messages: 17
Registered: February 2012
Junior Member
Hi,

I have this problem for so long and I really hope someone can help me on this forum.

Background about my project
-------------------------------------------
Dynamic web project using Java servlet 3.0, JSP, JPA with hibernate and Maven war plug in.
OS : Windows 10
Tomcat 9.1.0.

Eclipse Oxgen.

Basically, when I sent my jsp page, usually if I run debug server, there will be a step through stack that is shown on the debug screen.

However, no matter how many times I tried I am that getting that anymore no matter how I tried.

Please see attached a screen shot.

I only got alot of Daemon thread...and Eclipse it seems is not reading the code at all.

In addition, I noticed that the step in, step out etc are all greyed out.

Also, when I pressed terminated (the red box) since nothing happens, there was a line that said

<terminated>org.apache.catalina.startup.Bootstrap at localhost: 527914
<terminated, exit value: 1> C:\ProgramFiles\Java\jdk1.8.0.151\bin\javaw.exe

I would appreciate it if someone can let me know how to get debugging in IDE to behave normally again.

Thanks.


[Updated on: Fri, 02 February 2018 02:48]

Report message to a moderator

Previous Topic:can't remote debug
Next Topic:License management for Eclipse based products
Goto Forum:
  


Current Time: Tue Sep 25 15:27:31 GMT 2018

Powered by FUDForum. Page generated in 0.01724 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top