Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Possible corruption of p2 pool
Possible corruption of p2 pool [message #1781041] Wed, 31 January 2018 17:37 Go to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 353
Registered: March 2011
Senior Member
Hi.

I have several Eclipse environments, some installed with Oomph and some not, but with a shared p2 pool. When running on the command-line I started noticing that these environments produce the same errors with missing features and plugins from the pool (see below). The missing features and plugins are the same for the different environments. The relevant features and plugins are almost all EMF-related.

Nevertheless, I see that the features and plugins (matching the exact versions) are in the pool.

However the plugins with those versions have size 0!

I'm not sure if this is an Oomph issue or p2, but since I manage these with Oomph, I wanted to rule things out first.

I have used the Eclipse installer to clean-up the p2 agent, removing several profiles and artifacts. Is it possible that removing a profile can cause these problems?

Why do I get missing feature errors if the features do exist in the pool?

Why do I get 0-sized plugins?

How safe is it to have separate environments sharing the p2 pool when some were installed with Oomph and some were not?

Thanks


!ENTRY org.eclipse.update.configurator 4 0 2018-01-31 12:03:23.430
!MESSAGE Unable to find feature.xml in directory: /Users/epp/.p2/pool/features/org.eclipse.emf.ecp.sdk.feature_1.12.0.20170227-1527

!ENTRY org.eclipse.update.configurator 4 0 2018-01-31 12:03:23.436
!MESSAGE Unable to find feature.xml in directory: /Users/epp/.p2/pool/features/org.eclipse.emf.ecp.view.model.controls.feature_1.12.0.20170227-1527

!ENTRY org.eclipse.update.configurator 4 0 2018-01-31 12:03:23.438
!MESSAGE Unable to find feature.xml in directory: /Users/epp/.p2/pool/features/org.eclipse.emf.ecp.view.unset.feature_1.12.0.20170227-1527

!ENTRY org.eclipse.update.configurator 4 0 2018-01-31 12:03:30.979
!MESSAGE Unable to access file "plugins/org.eclipse.emf.cdo.admin_4.1.400.v20160302-0807.jar!META-INF/MANIFEST.MF".

!ENTRY org.eclipse.update.configurator 4 0 2018-01-31 12:03:32.912
!MESSAGE Unable to access file "plugins/org.eclipse.emf.ecp.emf2web.json_1.0.0.20170227-1527.jar!META-INF/MANIFEST.MF".

!ENTRY org.eclipse.update.configurator 4 0 2018-01-31 12:03:33.076
!MESSAGE Unable to access file "plugins/org.eclipse.emf.ecp.ui.e3.source_1.12.0.20170227-1527.jar!META-INF/MANIFEST.MF".

!ENTRY org.eclipse.update.configurator 4 0 2018-01-31 12:03:33.131
!MESSAGE Unable to access file "plugins/org.eclipse.emf.ecp.view.categorization.model.source_1.12.0.20170227-1527.jar!META-INF/MANIFEST.MF".

!ENTRY org.eclipse.update.configurator 4 0 2018-01-31 12:03:34.058
!MESSAGE Unable to access file "plugins/org.eclipse.emf.emfstore.example.installer_1.8.1.v20161125-1451.jar!META-INF/MANIFEST.MF".

!ENTRY org.eclipse.update.configurator 4 0 2018-01-31 12:03:35.500
!MESSAGE Unable to access file "plugins/org.eclipse.emfforms.swt.core_1.12.0.20170227-1527.jar!META-INF/MANIFEST.MF".

!ENTRY org.eclipse.update.configurator 4 0 2018-01-31 12:03:44.331
!MESSAGE Unable to access file "plugins/org.eclipse.net4j.ui_4.2.300.v20160301-1326.jar!META-INF/MANIFEST.MF".
Re: Possible corruption of p2 pool [message #1781062 is a reply to message #1781041] Thu, 01 February 2018 04:25 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29552
Registered: July 2009
Senior Member
Removing a profile won't remove any artifacts. Only the garbage collection of the pool will remove artifacts that are no longer referenced by any profile. Of course if you remove a profile that's still actually used and then garbage collect, that would be a problem. But that doesn't really explain empty jars.

Have you tried to do a repair of the agent, looking for damaged artifacts? The pool is an artifact repository so it has an artifacts.xml in the root. It will be good to look and see if the above broken things are listed in the artifacts.xml. If they are, they should be detected as damaged and should be repairable.
Re: Possible corruption of p2 pool [message #1781122 is a reply to message #1781062] Thu, 01 February 2018 16:17 Go to previous messageGo to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 353
Registered: March 2011
Senior Member
Hi.

Well, the specific versions of the features and plugins are missing from artifacts.xml.

In the Installer, in the Bundle Pool Analysis dialog I selected all profiles and let it look for damaged artifacts, but it didn't find any. In fact it doesn't show the ones with size 0. I suppose that's because the bad ones are not in artifacts.xml.

Nevertheless, I tried selecting one of those with the same name, but different version and chose "Repair Selected" but I got a dialog saying "Some artifacts could not be downloaded from the repositories listed in the profiles. Please check additional repositories and try again." Even selecting all repositories I got back the same message.

I looked into the details of the profiles for the environments that show the error messages, and under Installed Units I can find the bundles, but with a more recent version (which are in the pool).

Hmmm...

Re: Possible corruption of p2 pool [message #1781149 is a reply to message #1781122] Fri, 02 February 2018 04:44 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29552
Registered: July 2009
Senior Member
Hmmm, it makes you think that perhaps org.eclipse.update.configurator is looking older versions of the profile (each folder ~/.p2/org.eclipse.equinox.p2.engine/profileRegistry* is a profile folder for something with timestamped named versions). Or perhaps it is is looking in eclipse/configuration/org.eclipse.update/platform.xml or in eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info.
Previous Topic:Problem building oomph
Next Topic:Oomph headless
Goto Forum:
  


Current Time: Tue Sep 25 11:34:57 GMT 2018

Powered by FUDForum. Page generated in 0.02635 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top