Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Kura » OPC DEMO - write variable(cannot write)
OPC DEMO - write variable [message #1780964] Tue, 30 January 2018 14:02 Go to next message
Marco Noto is currently offline Marco NotoFriend
Messages: 6
Registered: November 2017
Location: Turin
Junior Member
Good morning. I'm using opc/ua server simulator from https://eclipse.github.io/kura/wires/kura-wires-opcua.html.

I'm trying to write a value in the fan variable, but it doesn't seem to work. I use a subscriber linked to the asset and i send a json message like {"metrics":{"fan":1}}, please see image.
Does the demo server support writing?
Thanks in advance

marco.
  • Attachment: Cattura.JPG
    (Size: 82.28KB, Downloaded 86 times)
  • Attachment: Cattura2.JPG
    (Size: 25.97KB, Downloaded 63 times)
  • Attachment: Cattura3.JPG
    (Size: 71.38KB, Downloaded 65 times)
  • Attachment: Cattura4.JPG
    (Size: 109.68KB, Downloaded 64 times)
Re: OPC DEMO - write variable [message #1781052 is a reply to message #1780964] Wed, 31 January 2018 20:48 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 262
Registered: July 2015
Location: Italy
Senior Member
Hi,
it should support writing.
Testing a write from the data tab in drivers and assets result in a proper value written into the server?

Best regards,
Matteo
Re: OPC DEMO - write variable [message #1781160 is a reply to message #1781052] Fri, 02 February 2018 08:29 Go to previous messageGo to next message
Marco Noto is currently offline Marco NotoFriend
Messages: 6
Registered: November 2017
Location: Turin
Junior Member
In the data table works partially, in the sense that any value I enter, the result is to obtain 1, see screenshot please.
Re: OPC DEMO - write variable [message #1781161 is a reply to message #1781160] Fri, 02 February 2018 08:33 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 262
Registered: July 2015
Location: Italy
Senior Member
Hi,
for what I remember of that demo, those channels are booleans.
Best regards,
Matteo
Re: OPC DEMO - write variable [message #1781178 is a reply to message #1781161] Fri, 02 February 2018 10:24 Go to previous messageGo to next message
Marco Noto is currently offline Marco NotoFriend
Messages: 6
Registered: November 2017
Location: Turin
Junior Member
I follow the https://eclipse.github.io/kura/wires/kura-wires-opcua.html documentation:

https://eclipse.github.io/kura/assets/images/wires/OPCUADriverConfig.png
Re: OPC DEMO - write variable [message #1781180 is a reply to message #1781178] Fri, 02 February 2018 10:33 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 262
Registered: July 2015
Location: Italy
Senior Member
Uhm, right, it could be that the integer type is supported but only in the range [0,1].
Since it maps a fan it was meant only to activate/deactivate a fan and this simulation bundle was developed to simulate this behaviour.

Best regards
Re: OPC DEMO - write variable [message #1782129 is a reply to message #1781180] Mon, 19 February 2018 10:36 Go to previous messageGo to next message
Vito Scornavacche is currently offline Vito ScornavaccheFriend
Messages: 6
Registered: February 2018
Junior Member
Hi there,
i have the same problem. I can not write variable using the OPC UA asset.
I tried with the standard simulator of kura for OPC UA drivers.

I used also two other simulators (Prosys OPC UA Simulation Server and OpenOpcUa Core Server) to be sure that is not a simulator fault and it didn't even work.
It is a driver bug or am I doing some mistake?
Re: OPC DEMO - write variable [message #1782130 is a reply to message #1781180] Mon, 19 February 2018 10:42 Go to previous message
Vito Scornavacche is currently offline Vito ScornavaccheFriend
Messages: 6
Registered: February 2018
Junior Member
Hi there,
I am having the same problem. I tried to overwrite some variables in the OPC UA simulator server and it did not work.

I also tried two others simulator servers (Prosys OPC UA Simulation Server and OpenOpcUa Core Server) to be sure that is not a simulator fault and it did not even work.

So is it a driver problem or am i doing some mistake?
Previous Topic:Kura Emulator - missing native library for RXTX
Next Topic:Mqtt message capacity
Goto Forum:
  


Current Time: Fri Sep 21 08:04:13 GMT 2018

Powered by FUDForum. Page generated in 0.26107 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top