Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » EGit update site broken?
EGit update site broken? [message #1780775] Fri, 26 January 2018 23:37 Go to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 361
Registered: March 2011
Senior Member
Hi. Sorry for cross-forum posting, but I'm not sure if this is an Oomph problem, or an EGit problem, but at least there is an Oomph angle to it.

I'm developing a simple setup model which includes several standard features such as the eclipse platform, emf, uml2, mwe2, papyrus, papyrus sysml and a few others, all on an Oxygen stream and with standard p2 URLs. However I get the error below complaining that the EGit update site p2 repo ( http://download.eclipse.org/egit/updates) cannot be read.

Note that my setup model *does not* explicitly list the EGit repo, so it looks like it is added by Oomph automatically. Is this so?

However that repo seems to be correct. You can check it in Oomph's Repository Explorer and everything seems to be in place.

Nevertheless, I tried to add this EGit repo to a plain, minimal Eclipse platform installation (without anything, i.e. http://download.eclipse.org/eclipse/downloads/drops4/R-4.7.2-201711300510/download.php?dropFile=eclipse-platform-4.7.2-macosx-cocoa-x86_64.dmg) manually rather than with Oomph and found out that the following:

1. doing this in my user account (where I normally use Oomph and Eclipse) and it works fine (no p2 provision errors)
2. but doing this in a new fresh user that has no traces of Eclipse I get a very similar error (at the bottom).

This suggests that maybe there is some implicit dependency from EGit, is this so?

Thanks


ERROR: org.eclipse.equinox.p2.metadata.repository code=1002 Unable to read repository at http://download.eclipse.org/egit/updates.
org.tukaani.xz.XZFormatException: Input is not in the XZ format
  at org.tukaani.xz.common.DecoderUtil.decodeStreamHeader(Unknown Source)
  at org.tukaani.xz.SingleXZInputStream.initialize(Unknown Source)
  at org.tukaani.xz.SingleXZInputStream.initialize(Unknown Source)
  at org.tukaani.xz.SingleXZInputStream.<init>(Unknown Source)
  at org.tukaani.xz.XZInputStream.<init>(Unknown Source)
  at org.tukaani.xz.XZInputStream.<init>(Unknown Source)
  at org.eclipse.equinox.internal.p2.metadata.repository.XZedSimpleMetadataRepositoryFactory.load(XZedSimpleMetadataRepositoryFactory.java:80)
  at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.factoryLoad(MetadataRepositoryManager.java:57)
  at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:768)
  at sun.reflect.GeneratedMethodAccessor25.invoke(Unknown Source)
  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
  at java.lang.reflect.Method.invoke(Method.java:498)
  at org.eclipse.oomph.util.ReflectUtil.invokeMethod(ReflectUtil.java:117)
  at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:409)
  at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:201)
  at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager$Metadata.loadRepository(CachingRepositoryManager.java:476)
  at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:96)
  at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:92)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$RepositoryLoader$Worker.perform(ProfileTransactionImpl.java:1613)
  at org.eclipse.oomph.util.WorkerPool$Worker.run(WorkerPool.java:428)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56)



Unable to read repository at http://download.eclipse.org/egit/updates.
Unable to read repository at http://download.eclipse.org/egit/updates.
Input is not in the XZ format

[Updated on: Fri, 26 January 2018 23:43]

Report message to a moderator

Re: EGit update site broken? [message #1780780 is a reply to message #1780775] Sat, 27 January 2018 04:14 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29653
Registered: July 2009
Senior Member
Both http://download.eclipse.org/egit/updates/content.xml.xz and http://download.eclipse.org/egit/updates/content.jar exist, the http://download.eclipse.org/egit/updates/p2.index looks correct instructing the use of the *.xml.xz first, and this site hasn't caused me any problems yesterday will testing EMF's new improved setup. So it seems not a problem with EGit's update site.
Re: EGit update site broken? [SOLVED] [message #1780976 is a reply to message #1780775] Tue, 30 January 2018 18:04 Go to previous message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 361
Registered: March 2011
Senior Member
This turns out to be unrelated to EGit. See Msg 1780975.
Previous Topic:Using gitlab flow with JGit
Next Topic:EGit push/pull crashes in presence of ed25519 key
Goto Forum:
  


Current Time: Mon Nov 19 06:50:16 GMT 2018

Powered by FUDForum. Page generated in 0.01528 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top