Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » p2 director install fails after successful compilation(p2 director PDE headless build)
p2 director install fails after successful compilation [message #1780765] Fri, 26 January 2018 17:41 Go to next message
Jeremy Fox is currently offline Jeremy FoxFriend
Messages: 1
Registered: January 2018
Junior Member
I have been fighting an issue with our headless PDE build for 2 weeks now and getting desperate for help!

We have a large RCP application that has been based on an Eclipse 3.7 target platform (using Java 7) that we are finally moving to Oxygen (and Java 8 JDK). I am to a point where everything runs fine in my Eclipse IDE with my Oxygen-based target platform and all dependencies are resolved. I have also updated our headless PDE Ant scripts to use Oxygen, and everything builds successfully. However, after the build, it fails during the "runDirector" stage where it tries to install my product's definition to the target. I am including relevant (trimmed down) log files to this post.

Of note, in the consoleText.txt file, lines 83-88 are complaining about not being able to find dependency plugins that I know for certain are in the target platform (and would not have compiled if they were not present). Further down (around line 161) is where runDirector starts, and attempts to download org.apache.ant 1.10.1, a plugin that is also included in the target platform already. It them proceeds to continue to try to download dependencies that are also already in the target platform.

Also of note, the referenced .log file (also included) is throwing an InvocationTargetException in AntRunner.run(). I have not been able to track why this is an issue, but I suspect it may be relevant.

I have scoured the web, this forum, and others for relevant information and tried everything I can find/think of to no avail. I will be most grateful for any assistance I can receive so that I can return to a state of sanity.
Re: p2 director install fails after successful compilation [message #1783665 is a reply to message #1780765] Thu, 15 March 2018 10:42 Go to previous message
Johannes Faltermeier is currently offline Johannes FaltermeierFriend
Messages: 83
Registered: December 2013
Member

Hi,

I am not an expert on headless PDE builds, so I am not sure what the problem is. However there seem to be a lot of messages about platform dependent bundles.
I know that since Eclipse Mars.1 there is no delta pack anymore. Maybe this is the root cause? See https://wiki.eclipse.org/A_Brief_Overview_of_Building_at_Eclipse#Preferred_way_of_doing_multi-platform_builds for more information.

Besides that, maybe it is a good time to also switch to Eclipse Tycho as a build tool (https://wiki.eclipse.org/Category:Tycho) as it has become the default as part of the Common Build Infrastructure for Eclipse Projects.

Best regards
Johannes


Johannes Faltermeier

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Previous Topic:Detect view in which a dynamic pulldown menu was opened
Next Topic:Plugin not auto starting in Eclipse
Goto Forum:
  


Current Time: Wed Nov 14 09:03:20 GMT 2018

Powered by FUDForum. Page generated in 0.02178 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top