Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Authentication problem since Java update 8u161
[CDO] Authentication problem since Java update 8u161 [message #1780295] Fri, 19 January 2018 16:30 Go to next message
Robert Schulk is currently offline Robert SchulkFriend
Messages: 42
Registered: July 2015
Member
Hi all,

we are experiencing a strange authentication error since the recent Java update 8u161. The same code worked fine with 8u151.

We are using the most recent CDO build.
Can anyone confirm this? I attached the test file as well as the stack trace.

Are we doing something strange, or does the CDO/Net4J implementation need to be updated?
Re: [CDO] Authentication problem since Java update 8u161 [message #1780326 is a reply to message #1780295] Sat, 20 January 2018 06:37 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6402
Registered: July 2009
Senior Member
I can confirm that this problem was introduced by Java 8 update 161, see http://www.oracle.com/technetwork/java/javase/8u161-relnotes-4021379.html#JDK-8185292 . Please submit a bugzilla, so that I can investigate a proper solution.

In the meantime you can set the following system property to work around the problem:

-Djdk.crypto.KeyAgreement.legacyKDF=true
Re: [CDO] Authentication problem since Java update 8u161 [message #1780355 is a reply to message #1780326] Sun, 21 January 2018 05:41 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6402
Registered: July 2009
Senior Member
I've submitted and resolved https://bugs.eclipse.org/bugs/show_bug.cgi?id=530088 . Please let me know if it solves the problem for you...
Re: [CDO] Authentication problem since Java update 8u161 [message #1780419 is a reply to message #1780355] Mon, 22 January 2018 10:35 Go to previous messageGo to next message
Robert Schulk is currently offline Robert SchulkFriend
Messages: 42
Registered: July 2015
Member
That was fast. Thanks so much!
The workaround as well as the new build are working for us.
Re: [CDO] Authentication problem since Java update 8u161 [message #1780443 is a reply to message #1780419] Mon, 22 January 2018 14:13 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6402
Registered: July 2009
Senior Member
I'm glad to hear that it works ;-)
Previous Topic:References not stored in xmi file when I save the objects
Next Topic:[Announce] Stop Support for GWT
Goto Forum:
  


Current Time: Tue Oct 23 07:30:54 GMT 2018

Powered by FUDForum. Page generated in 0.02219 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top