Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » WAR deployment to JBoss/Jetty(RAP demo is working well but RAP Examples does not working)
WAR deployment to JBoss/Jetty [message #1779539] Tue, 09 January 2018 12:16 Go to next message
NakKyu Sung is currently offline NakKyu SungFriend
Messages: 2
Registered: January 2018
Junior Member
Hello,

I just imported two projects (org.eclipse.rap.demo / org.eclipse.rap.examples) from plug ins.
Of course, both of two projects are running well on eclipse environment with integrated jetty server.
But after I exported these as file by using WAR Products (Incubation), only org.eclipse.rap.demo is running while org.eclipse.rap.examples is not running.
I could not see any error during deployment.

I have attachched the full source code from plug in and generated WAR file.
Please, kindly help to me to know what should I do.

Below is my environmrnt
Eclipse for RCP and RAP Developers
Version: Oxygen.2 Release (4.7.2)
Build id: 20171218-0600
JDK 1.8
Windows 10 64 bit
Jettey 9.3.22 server
JBoss EAP 6
Re: WAR deployment to JBoss/Jetty [message #1779621 is a reply to message #1779539] Wed, 10 January 2018 10:59 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2286
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
as mentioned here [1], please use Tycho build to generate the WAR file.

[1] https://www.eclipse.org/forums/index.php?t=tree&th=1087206&goto=1779532&#msg_1779532

Regards,
Ivan
Re: WAR deployment to JBoss/Jetty [message #1779622 is a reply to message #1779621] Wed, 10 January 2018 11:07 Go to previous message
NakKyu Sung is currently offline NakKyu SungFriend
Messages: 2
Registered: January 2018
Junior Member
Hi Ivan,
Thank for the reply and may I know why org.eclipse.rap.demo can be deployed and worked as well even though I used WAR Products (Incubation)?
Anyway, I will try to follow your suggestion and get back to you.
Thanks a lot again for your reply.

B.regards.
NakKyu
Previous Topic:title attribute in HTML Markup
Next Topic:Autocomplete doesn't work
Goto Forum:
  


Current Time: Tue Oct 16 07:49:02 GMT 2018

Powered by FUDForum. Page generated in 0.02899 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top