Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » <include> path lost on 64 bit upgrade, restored easily what do I add(installation mingw64 oxygen side by side install)
<include> path lost on 64 bit upgrade, restored easily what do I add [message #1779122] Wed, 03 January 2018 05:01 Go to next message
Robert Gray is currently offline Robert GrayFriend
Messages: 9
Registered: May 2017
Junior Member
Installed successfully minGW64, Oxygen, basically. Eclipse can't find my include files in my main.cpp though. A fresh hello world works fine 64 bit. If I change back my minggw_home var in environmental setting to the 32bit build <include>functionality is restored. Can someone please tell me what I need to add to the 64 bit installation path/var to restore include functionality instead of a hard coding workaround?

Best Regards

Update: 'retired' 32bit Luna based MinGW to a "holding"directory. Just renamed.

64bit MinGW64 renamed now c:\MinGW

it finds <> system files no problem. Ex: <iostream>
But it cant find <GL\glut.h> like it did before.
Have to hard code it:
from
#include <GL\glut.h>
to
#include "C:\MinGW\include\GL\glut.h"
**below**
What I noticed lately is that my original 32bit MinGW was "preset" with a GL folder to put graphics header files in. I never added it, it was already there. This 64bit MinGW installation didnt have that folder. I had to add it.
Did I miss a GL configuration option with the MinGW 64bit?

[Updated on: Wed, 03 January 2018 17:52]

Report message to a moderator

Re: <include> path lost on 64 bit upgrade, restored easily what do I add [message #1779291 is a reply to message #1779122] Thu, 04 January 2018 23:01 Go to previous message
Robert Gray is currently offline Robert GrayFriend
Messages: 9
Registered: May 2017
Junior Member
I had the wrong include folder. In MingW-> C:\minGW\mingw64\x86_64-w64-mingw32\include is the correct one.

A new problem emerged: a run time error after a successful compile & linking stage on my 32bit builds.

As dumb luck would have it, the following compiler flag fixed it:
-static-libgcc -static-libstdc++ in tool,miscellaneous under c++ mingw linker:

Add "-static-libgcc -static-libstdc++" as Linker flags for your new project. This text should be added to the Linker flags field, which can be found by right-clicking on the new Project in the Project Explorer and clicking on Properties. Under the Project Properties, expand the C/C++ Build menu and click on Settings. Under the Tool Settings tab, expand the MinGW C++ Linker menu and click on Miscellaneous. Add the text to the Linker flags field, then click the Apply button.
Click Build Project under the Project menu, then click Run under the Run menu.

[Updated on: Fri, 05 January 2018 02:07]

Report message to a moderator

Previous Topic:Unresolved inclusion: stdlib.h in file file:/usr/include/c++/6/cstdlib
Next Topic:Eclipse crashes after firs start
Goto Forum:
  


Current Time: Wed Jan 24 08:03:05 GMT 2018

Powered by FUDForum. Page generated in 0.02118 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software