Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Kura » Issue about set aws cloud services(Not enable to set Device SSL Certificate)
Issue about set aws cloud services [message #1778206] Mon, 11 December 2017 23:19 Go to next message
Yiming Liu is currently offline Yiming LiuFriend
Messages: 1
Registered: December 2017
Location: Dublin
Junior Member
Tried to set Cloud Services using aws iot.

However, I tried to set ssl cert in Kura UI Settings->Device SSL Certificate, after press "Apply", I got an error as attachment.

There is nothing in /var/log/kura-console.log.

Does anyone have ideas what's the problem?
Re: Issue about set aws cloud services [message #1778289 is a reply to message #1778206] Tue, 12 December 2017 16:29 Go to previous messageGo to next message
David Woodard is currently offline David WoodardFriend
Messages: 420
Registered: July 2014
Senior Member
Hello,

This error typically occurs when the private key is not in the format expected by Kura. Did you run this command from the documentation:

openssl pkcs8 -topk8 -inform PEM -outform PEM -in xxxxxxxxxx-private.pem.key -out outKey.pem -nocrypt
Re: Issue about set aws cloud services [message #1778290 is a reply to message #1778289] Tue, 12 December 2017 16:41 Go to previous message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 261
Registered: July 2015
Location: Italy
Senior Member
Hi,
adding to what correctly said by Dave: is the keystore properly referenced in the SSL page?

Best regards,
Matteo
Previous Topic:Web UI
Next Topic:errorRetrievingNodeId
Goto Forum:
  


Current Time: Fri Sep 21 06:19:36 GMT 2018

Powered by FUDForum. Page generated in 0.01908 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top