Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » GMF tooling -- Problems with generating the gmfgen model
GMF tooling -- Problems with generating the gmfgen model [message #1777025] Thu, 23 November 2017 16:21 Go to next message
Albrecht l is currently offline Albrecht lFriend
Messages: 1
Registered: November 2017
Junior Member
Hello,
I am a beginner in using GMF. I want to understand and maintain a system, which is few years old . I want to use
and rebuild it in eclipse Oxygen. Since gmf tooling is no longer shipped with eclipse i downlaoded it from there
updatesite http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases/. But when i try to generate the
gmfgen model i get the error below.
A similar error is also described in the previous post, but the user uses Papyrus. I Thing the guys of payrus have theire own
workaround. For now i am using Neon to learn gmf(tooling). Is there a way to use it with oxygen? Am i doing something wrong?

thanks in advance

Albrecht



Error:


java.lang.NoClassDefFoundError: org/eclipse/m2m/internal/qvt/oml/runtime/project/BundleUnitResolver
at org.eclipse.gmf.internal.xpand.util.BundleResourceManager.getQVTUnitResolver(BundleResourceManager.java:118)
at org.eclipse.gmf.internal.xpand.util.ResourceManagerImpl.doLoadQvtResource(ResourceManagerImpl.java:76)
at org.eclipse.gmf.internal.xpand.util.ResourceManagerImpl.loadQvtResourceThroughCache(ResourceManagerImpl.java:64)
at org.eclipse.gmf.internal.xpand.util.ResourceManagerImpl.loadQvtResource(ResourceManagerImpl.java:47)
at org.eclipse.gmf.internal.xpand.model.Scope.findExtension(Scope.java:148)
at org.eclipse.gmf.internal.xpand.model.ExecutionContextImpl.getImportedModules(ExecutionContextImpl.java:293)
at org.eclipse.gmf.internal.xpand.model.ExecutionContextImpl.getOCLEnvironment(ExecutionContextImpl.java:254)
at org.eclipse.gmf.internal.xpand.ocl.TypeHelper.getTypeForName(TypeHelper.java:35)
at org.eclipse.gmf.internal.xpand.model.ExecutionContextImpl.findDefinition(ExecutionContextImpl.java:231)
at org.eclipse.gmf.internal.xpand.model.ExecutionContextImpl.findDefinition(ExecutionContextImpl.java:167)
at org.eclipse.gmf.internal.xpand.XpandFacade.evaluate(XpandFacade.java:54)
at org.eclipse.gmf.graphdef.codegen.FigureGenerator.fqnSwitch(FigureGenerator.java:85)
at org.eclipse.gmf.internal.bridge.genmodel.InnerClassViewmapProducer.createViewmap(InnerClassViewmapProducer.java:123)
at org.eclipse.gmf.internal.bridge.genmodel.InnerClassViewmapProducer.create(InnerClassViewmapProducer.java:76)
at org.eclipse.gmf.internal.bridge.genmodel.DiagramGenModelTransformer.process(DiagramGenModelTransformer.java:413)
at org.eclipse.gmf.internal.bridge.genmodel.MappingTransformer.transform(MappingTransformer.java:31)
at org.eclipse.gmf.internal.bridge.transform.TransformToGenModelOperation$2.process(TransformToGenModelOperation.java:446)
at org.eclipse.gmf.internal.bridge.transform.TransformToGenModelOperation.executeTransformation(TransformToGenModelOperation.java:272)
at org.eclipse.gmf.internal.bridge.ui.dashboard.actions.TransformMap2GenModelAction.run(TransformMap2GenModelAction.java:65)
at org.eclipse.gmf.internal.bridge.ui.dashboard.HyperlinkFigure$1.mousePressed(HyperlinkFigure.java:63)
at org.eclipse.draw2d.Figure.handleMousePressed(Figure.java:938)
at org.eclipse.draw2d.SWTEventDispatcher.dispatchMousePressed(SWTEventDispatcher.java:242)
at org.eclipse.draw2d.LightweightSystem$EventHandler.mouseDown(LightweightSystem.java:523)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:193)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:86)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4428)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4238)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3817)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1150)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1039)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:153)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:680)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:594)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:151)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
at org.eclipse.equinox.launcher.Main.main(Main.java:1472)
Caused by: java.lang.ClassNotFoundException: org.eclipse.m2m.internal.qvt.oml.runtime.project.BundleUnitResolver cannot be found by org.eclipse.gmf.xpand_2.2.0.201409171321
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:484)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 51 more
Re: GMF tooling -- Problems with generating the gmfgen model [message #1785156 is a reply to message #1777025] Tue, 10 April 2018 07:20 Go to previous messageGo to next message
Suv Yathiraj is currently offline Suv YathirajFriend
Messages: 1
Registered: April 2018
Junior Member
Encountering same problem with Oxygen 3 and GMF 3.0.1. Tried adding M2M runtime libraries to the classpath. Still no use. Any suggestions?
Re: GMF tooling -- Problems with generating the gmfgen model [message #1785216 is a reply to message #1785156] Wed, 11 April 2018 06:12 Go to previous message
Pierre-Charles David is currently offline Pierre-Charles DavidFriend
Messages: 448
Registered: July 2009
Senior Member
To my knowledge, GMF Tooling is not maintained anymore. I'm not even sure anyone from the project is following this forum. The only suggestion I can give you is to keep an older version of Eclipse (pre-Oxygen) around for when you need to launch a GMF Tooling generation, even if you use a more recent Eclipse for the main development. The version of Eclipse (and the required dependencies) used to run the code generation phase does not need to be the version you use to develop the rest of the code, or the target version where the result application will be executed.

Pierre-Charles David - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Previous Topic:Split Editor
Next Topic:Attach Other Figures/EditParts to a Connection
Goto Forum:
  


Current Time: Thu Oct 18 14:00:51 GMT 2018

Powered by FUDForum. Page generated in 0.02001 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top