Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Understanding the Architecture Framework
Understanding the Architecture Framework [message #1776450] Thu, 16 November 2017 14:14 Go to next message
Patrik Nandorf is currently offline Patrik NandorfFriend
Messages: 165
Registered: January 2013
Location: Sweden
Senior Member
Hi!

Is there a simple working example of the Architecture Framework somewhere?

And please don't point to Papyrus-RT.

/Patrik
Re: Understanding the Architecture Framework [message #1776457 is a reply to message #1776450] Thu, 16 November 2017 14:55 Go to previous messageGo to next message
Benoit Maggi is currently offline Benoit MaggiFriend
Messages: 129
Registered: March 2013
Location: Bordeaux, France
Senior Member
Hi Patrik,

Not sure what do you expect by "simple".

Here is a list of existing architecture:
UML: https://git.eclipse.org/c/papyrus/org.eclipse.papyrus.git/tree/plugins/uml/architecture/org.eclipse.papyrus.uml.architecture/model/uml.architecture
BPMN: https://git.eclipse.org/c/papyrus/org.eclipse.papyrus-bpmn.git/tree/org.eclipse.papyrus.bpmn.architecture/model/bpmn.architecture
SysML 1.4: https://git.eclipse.org/c/papyrus/org.eclipse.papyrus-sysml.git/tree/gui/org.eclipse.papyrus.sysml14.architecture/resources/sysml14.architecture
Library (Work in progress): https://github.com/bmaggi/library-training/blob/master/org.eclipse.papyrus.training.library.architecture/resources/library.architecture

Regards,
/Benoit



Re: Understanding the Architecture Framework [message #1776468 is a reply to message #1776457] Thu, 16 November 2017 16:21 Go to previous messageGo to next message
Patrik Nandorf is currently offline Patrik NandorfFriend
Messages: 165
Registered: January 2013
Location: Sweden
Senior Member
Thanks Benoit,

The library-training looks promising. However when I clone and run it I get the same issue I have which is that I cannot create elements from the palette. See https://youtu.be/1BpUaSbLXos

In my case I've verified that the element types are there and I can create elements in the model explorer through a 'new child' menu.

What I'm struggeling with is the palette/architecture models (I guess).

/Patrik
Re: Understanding the Architecture Framework [message #1776470 is a reply to message #1776468] Thu, 16 November 2017 16:55 Go to previous messageGo to next message
Benoit Maggi is currently offline Benoit MaggiFriend
Messages: 129
Registered: March 2013
Location: Bordeaux, France
Senior Member
Hum, it's working on my computer.

Do you have any log in error log view ?
Re: Understanding the Architecture Framework [message #1776485 is a reply to message #1776470] Thu, 16 November 2017 22:00 Go to previous messageGo to next message
Patrik Nandorf is currently offline Patrik NandorfFriend
Messages: 165
Registered: January 2013
Location: Sweden
Senior Member
I'll do a fresh install of Papyrus Oxygen tomorrow and try again.

/Patrik
Re: Understanding the Architecture Framework [message #1776511 is a reply to message #1776485] Fri, 17 November 2017 08:15 Go to previous messageGo to next message
Patrik Nandorf is currently offline Patrik NandorfFriend
Messages: 165
Registered: January 2013
Location: Sweden
Senior Member
I did a clean install and now the library-training works. However mine doesn't work. The issue is the same, ie I cant drag and drop from the palette.

AFAIK the element types (both semantic and diagramatic) seem ok. Is these a way to create a palette and test it without using an architecture model. Just to verify that the palette-configuration is ok?



Re: Understanding the Architecture Framework [message #1776537 is a reply to message #1776511] Fri, 17 November 2017 12:38 Go to previous messageGo to next message
Benoit Maggi is currently offline Benoit MaggiFriend
Messages: 129
Registered: March 2013
Location: Bordeaux, France
Senior Member
You can try using this extension point
org.eclipse.papyrus.infra.gmfdiag.common.paletteDefinition

at "some point" during Oxygen development it was working
(before regrouping all palette in the UML architecture)

See: https://git.eclipse.org/r/#/c/92099/14/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/plugin.xml
And the Palette https://git.eclipse.org/r/#/c/92099/14/plugins/uml/diagram/org.eclipse.papyrus.uml.diagram.clazz/model/PapyrusUMLClassDiagram.paletteconfiguration

=> I can't guarantee that it's still working.

Did you set up some validation tests for your models ?
You can reuse this one to validate your model : https://gist.github.com/bmaggi/8523564340eec9dc86ba1f34b26bb048
You should also ensure that emf ids are similar to string identifier https://gist.github.com/bmaggi/2cac5e3529fc0d0314a80ee8e6e6fa1a

With these 2 tests, I caught most errors while building SysML 1.4 DSML.
Re: Understanding the Architecture Framework [message #1776750 is a reply to message #1776537] Tue, 21 November 2017 07:58 Go to previous messageGo to next message
Patrik Nandorf is currently offline Patrik NandorfFriend
Messages: 165
Registered: January 2013
Location: Sweden
Senior Member
Thanks Benoit,

I couldn't make old palette extension work.

I ran the tests on elementtypes-model, architecture as well as palette models and still no luck.

/Patrik
Re: Understanding the Architecture Framework [message #1776753 is a reply to message #1776750] Tue, 21 November 2017 08:35 Go to previous messageGo to next message
Patrik Nandorf is currently offline Patrik NandorfFriend
Messages: 165
Registered: January 2013
Location: Sweden
Senior Member
I haven't set any advice on the element types, i just generated them from the profile. Shouldn't that be sufficient?

If I want to debug to see if any of the advice are preventing the creation. Where do I set the break point? It was some time ago I did it so I don't remember anymore.

Re: Understanding the Architecture Framework [message #1776754 is a reply to message #1776750] Tue, 21 November 2017 08:35 Go to previous messageGo to next message
Patrik Nandorf is currently offline Patrik NandorfFriend
Messages: 165
Registered: January 2013
Location: Sweden
Senior Member
I haven't set any advice on the element types, i just generated them from the profile. Shouldn't that be sufficient?

If I want to debug to see if any of the advice are preventing the creation. Where do I set the break point? It was some time ago I did it so I don't remember anymore.

Re: Understanding the Architecture Framework [message #1776806 is a reply to message #1776754] Tue, 21 November 2017 19:38 Go to previous message
Patrik Nandorf is currently offline Patrik NandorfFriend
Messages: 165
Registered: January 2013
Location: Sweden
Senior Member
I solved it.

The issue was that the generated DI elementtypesconfiguration didn't generate types specializing Component_PackagedElementShape. I did try to change the specialization type to Component_PackagedElementShape but missed to also change the hint also to Component_PackagedElementShape.

The second problem I had was to be able to drop a container into a container from the palette. I assumed that the DI element type would be Component_PackagedElementShape_CN (which I understand stands for ChildNode) but apparently (after trial and error) I found it to be Component_PackagedElementShape_CCN which I find unlogical.

All and all, this shows how complex it is to figure out what DI element type to use and it would be nice if this somehow could be simplified.

/Patrik
Previous Topic:Imported C++ registered package
Next Topic:Some questions on styles and css
Goto Forum:
  


Current Time: Tue Nov 13 20:13:40 GMT 2018

Powered by FUDForum. Page generated in 0.02719 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top