Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » <property name="eclipselink.canonicalmodel.generate_timestamp" value="false"/(When we set the property <property name="eclipselink.canonicalmodel.generate_timestamp" value="false"/> it is ignored by EclipseLink v2.7.0)
<property name="eclipselink.canonicalmodel.generate_timestamp" value="false"/ [message #1775319] Fri, 27 October 2017 15:17 Go to next message
Amita Mehta is currently offline Amita MehtaFriend
Messages: 25
Registered: May 2013
Junior Member
When we set the property <property name="eclipselink.canonicalmodel.generate_timestamp" value="false"/> it is ignored by EclipseLink v2.7.0

The metamodel files generated still has the timestamp.
Debugging through it shows that the property is still true and the setting it to false in the persistence.xml is ignored.

Are there any other properties that we need to set so that timestamp iks not generated?

Thanks for the help.
Re: <property name="eclipselink.canonicalmodel.generate_timestamp" value="false&qu [message #1775535 is a reply to message #1775319] Tue, 31 October 2017 16:23 Go to previous messageGo to next message
Lukas JungmannFriend
Messages: 30
Registered: November 2013
Location: Prague, Czech Republic
Member
How are you setting this property? It is intended to be passed to modelgen through '-Aeclipselink.canonicalmodel.generate_timestamp=false' javac option and that works for me
Re: <property name="eclipselink.canonicalmodel.generate_timestamp" value="false&qu [message #1775536 is a reply to message #1775319] Tue, 31 October 2017 16:24 Go to previous message
Lukas JungmannFriend
Messages: 30
Registered: November 2013
Location: Prague, Czech Republic
Member
How are you setting this property? It is intended to be passed to modelgen through '-Aeclipselink.canonicalmodel.generate_timestamp=false' javac option and that works for me
Previous Topic:2 or more constraints when doing anyOf
Next Topic:Dynamic explore xsd attributes or metadata information through Moxy question
Goto Forum:
  


Current Time: Sun Oct 21 17:34:32 GMT 2018

Powered by FUDForum. Page generated in 0.02142 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top