Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » CSS not apply(Style is partially apply on shape)
CSS not apply [message #1774864] Fri, 20 October 2017 16:11 Go to next message
Ismael Soulama is currently offline Ismael SoulamaFriend
Messages: 39
Registered: November 2016
Member
Hi there,
I have define my stereotype and i whant to apply a style on it.
I've follow the guide instruction, but on my shape, only the font color is apply.

Quote:

StateMachineDiagram State[appliedStereotypes~=MyCustomStereo]{
fontColor:#ff8d6d;
fillColor:#ffffff;
}


The fill color is ignore. The result is the default fill color.
Is there a way to force the style, like "important" in HTML, or did I miss something?
Re: CSS not apply [message #1775023 is a reply to message #1774864] Mon, 23 October 2017 15:23 Go to previous messageGo to next message
Quentin Le Menez is currently offline Quentin Le MenezFriend
Messages: 25
Registered: September 2014
Location: Paris Saclay, France
Junior Member
Hi,
This looks fine to me but as far as I know ffffff is white, which should be the default color.
Try using another one and see if changes something.

HTH,
Quentin
Re: CSS not apply [message #1775060 is a reply to message #1775023] Tue, 24 October 2017 09:18 Go to previous messageGo to next message
Ismael Soulama is currently offline Ismael SoulamaFriend
Messages: 39
Registered: November 2016
Member
Hi Quentin,
I've tried other colors, but the result is the same. The default background color appears to be a gradient of blue:
index.php/fa/31115/0/
And it don't change.
I've tried only "white" in place of fffff, and added "gradient:none". No result.
Re: CSS not apply [message #1775236 is a reply to message #1775060] Thu, 26 October 2017 15:16 Go to previous messageGo to next message
Ismael Soulama is currently offline Ismael SoulamaFriend
Messages: 39
Registered: November 2016
Member
Hi,
I've found that code in papyrus css theme:
* {
	fillColor:#C3D1D5;
	gradient: white vertical;
	elementIcon: true;
}


it's the default color applied on my shape.
Maybe the "*" is apply after my style, or his properties are'n't overridable ?
Re: CSS not apply [message #1775276 is a reply to message #1775236] Fri, 27 October 2017 06:57 Go to previous message
Maxime Defrances is currently offline Maxime DefrancesFriend
Messages: 5
Registered: October 2017
Junior Member
Do anyone know the keyword to modify Communication Paths from Use Case Diagram with CSS ?
Thank you
Previous Topic:[Papyrus on MaxOSX] - Right click and focus
Next Topic:Representation of Data type with DateTime interval type using MARTE
Goto Forum:
  


Current Time: Thu Apr 26 17:43:40 GMT 2018

Powered by FUDForum. Page generated in 0.01930 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software