Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » After updating Eclipse NEON to Oxygen, errors
After updating Eclipse NEON to Oxygen, errors [message #1774629] Wed, 18 October 2017 07:00 Go to next message
Alain Roger is currently offline Alain RogerFriend
Messages: 37
Registered: May 2010
Location: Slovakia
Member
Hi,

I had Eclipse NEON 3 install on my laptop, once i tried to upgrade it to Eclipse Oxygen (4.7.1) i got error message in my log as following:

SESSION 2017-10-18 08:49:52.772 -----------------------------------------------
eclipse.buildId=4.7.1.M20171009-0410
java.version=1.8.0_111
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.php.product
Command-line arguments:  -os linux -ws gtk -arch x86_64 -product org.eclipse.epp.package.php.product

!ENTRY org.eclipse.osgi 4 0 2017-10-18 08:49:57.266
!MESSAGE Application error
!STACK 1
java.lang.LinkageError: loader constraint violation: loader (instance of org/eclipse/osgi/internal/loader/EquinoxClassLoader) previously initiated loading for a different type with name "org/eclipse/core/commands/IHandler"
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.defineClass(ModuleClassLoader.java:276)
	at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.defineClass(ClasspathManager.java:655)
	at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findClassImpl(ClasspathManager.java:578)
	at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClassImpl(ClasspathManager.java:538)
	at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:525)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:328)
	at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:368)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:446)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	at org.eclipse.core.commands.Command.setHandler(Command.java:974)
	at org.eclipse.ui.internal.commands.CommandPersistence.readCommandsFromRegistry(CommandPersistence.java:210)
	at org.eclipse.ui.internal.commands.CommandPersistence.reRead(CommandPersistence.java:502)
	at org.eclipse.ui.internal.CommandToModelProcessor.process(CommandToModelProcessor.java:68)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:55)
	at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:305)
	at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:233)
	at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:107)
	at org.eclipse.e4.ui.internal.workbench.ModelAssembler.runProcessor(ModelAssembler.java:362)
	at org.eclipse.e4.ui.internal.workbench.ModelAssembler.runProcessors(ModelAssembler.java:324)
	at org.eclipse.e4.ui.internal.workbench.ModelAssembler.processModel(ModelAssembler.java:97)
	at org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadMostRecentModel(ResourceHandler.java:197)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.loadApplicationModel(E4Application.java:378)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:253)
	at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:614)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:594)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:151)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1472)


basically i understand that :java.lang.LinkageError: loader constraint violation: loader (instance of org/eclipse/osgi/internal/loader/EquinoxClassLoader) previously initiated loading for a different type with name "org/eclipse/core/commands/IHandler"

is the error. SO what should i do ? Because updating process happened correctly.

thx


what does not kill you, makes you stronger
http://www.rogtek.com
http://www.facebook.com/rogtek
Re: After updating Eclipse NEON to Oxygen, errors [message #1774634 is a reply to message #1774629] Wed, 18 October 2017 07:24 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29034
Registered: July 2009
Senior Member
Does that happen if you start it with a brand new fresh empty workspace? If that works okay, you might try to delete <workspace>/.metadata/.plugins/org.eclipse.e4.workbench/workbench.xmi and start up with that workspace again; this will forget about the current UI state of the workspace, i.e., open perspectives, layouts of views in each perspective. I only suggest this as a possibility because it looks like the problem happens while restoring the workbench state...
Re: After updating Eclipse NEON to Oxygen, errors [message #1774662 is a reply to message #1774634] Wed, 18 October 2017 11:57 Go to previous messageGo to next message
Alain Roger is currently offline Alain RogerFriend
Messages: 37
Registered: May 2010
Location: Slovakia
Member
I already deleted the whole /workspace folder and restart Eclipse. It still did it.

In fact this issue appeared once i upgrade Neon.3 (eclipse 4.6.3) to Oxygen.1 (4.7.1)


what does not kill you, makes you stronger
http://www.rogtek.com
http://www.facebook.com/rogtek
Re: After updating Eclipse NEON to Oxygen, errors [message #1774671 is a reply to message #1774662] Wed, 18 October 2017 13:40 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29034
Registered: July 2009
Senior Member
Sorry, it's not a great suggestion, but if you've been using the installer to create your installations you should be able to create a fresh new Oxygen installation in a matter of minutes... Hopefully that won't have the problem you're seeing; I expect not...

Previous Topic:EMF project error
Next Topic:Error CheckModel
Goto Forum:
  


Current Time: Wed Dec 13 16:58:54 GMT 2017

Powered by FUDForum. Page generated in 0.02727 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software