Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse install Oxygen: 1002 Unable to connect to repository (Unable to install eclips-cs)
Eclipse install Oxygen: 1002 Unable to connect to repository [message #1773526] Thu, 28 September 2017 21:19 Go to next message
Douglas Litke is currently offline Douglas LitkeFriend
Messages: 1
Registered: September 2017
Junior Member
ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 Unable to connect to repository ....compositeContent.xml

Using Oomph.

I can't put the error message or instruction location in the body, as this system says I am not allowed to yet (need more messages) Full error message in the attachment, along with the link to the instructions for installing opendaylight using Oomph

Using Eclipse Oxygen

The instructions say if I get an error 1002, to try waiting a couple of hours, try multiple times, try offline, and try without p2.j
I have tried 20 times, over 8 hours
I have tried offline
without p2, it fails for a missing ini file (I assume that file would have been installed if p2 had been installed).

I can currently open compositeContent.xml in my browser, though early this morning, that was not true.
Sometime the error is for content.xml (without the composite part of the name).

I have tried deleting the directories .p2 .eclipse eclipse, and the directory the code went into -- controller-master.

My connection is via hardwired Ethernet to the router. FIOS after the router.

Any suggestions how to get around this issue?? Or solve it ??


Thanks for your kind assistance.
Re: Eclipse install Oxygen: 1002 Unable to connect to repository [message #1773563 is a reply to message #1773526] Fri, 29 September 2017 12:32 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29033
Registered: July 2009
Senior Member
If I recall correctly the update site http://eclipse-cs.sf.net/update/ had problem with certificate authentication with older versions of Java that didn't have accept certificate's root. Perhaps that's the problem. I can access http://eclipse-cs.sf.net/update/ in my installation's Repository Explorer right now, and I do even have that installed, so it did work at that point in time too. Which version of Java are you using? Perhaps updating it to the latest Java 8 will help... Note that if you install Java 9, you're likely to run into this problem: https://wiki.eclipse.org/Configure_Eclipse_for_Java_9#Configure_Eclipse_for_Java_9_modules
Previous Topic:About JETTY upload file
Next Topic:Downloading Eclipse for Java Error
Goto Forum:
  


Current Time: Mon Dec 11 15:33:57 GMT 2017

Powered by FUDForum. Page generated in 0.02835 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software