Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Further on Updating the Java version in Eclipse?
Further on Updating the Java version in Eclipse? [message #1772880] Mon, 18 September 2017 09:46 Go to next message
RajibKumar Bandopadhyay is currently offline RajibKumar BandopadhyayFriend
Messages: 58
Registered: July 2014
Member
Please refer to this post, Updating to the latest JavaSE 8 in an older version of Eclipse?

Perused the instructions in the latest
Eclipse documentation - Current Release
Eclipse Oxygen


However, the Version JRE1.8 doesn't yet show up on the list of "Execution Environments"! What to do to have it show up in the said list?
Also, I wish to know about How To Install:
(a) Standard VM 1.x.x ... ?
(b) Execution Environment Description ... ?
How to? In the help instruction, it says :
Quote:
Standard 1.1.x VM:
Follow the same steps as for Standard VM JREs.
...

But when I follow the steps for (a) Standard VM 1.x.x , the system says: Quote:
Target is not a JDK root. System library was not found.

The same for (b) Execution Environment Description

The help has a link to a wiki: Execution Environment Description. I skimmed through it. It explains about the environment description, not how to install it. Or maybe, as I am a newbie, I am still an idiot ;-)

[Updated on: Mon, 18 September 2017 10:57]

Report message to a moderator

Re: Further on Updating the Java version in Eclipse? [message #1772892 is a reply to message #1772880] Mon, 18 September 2017 13:07 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3595
Registered: July 2009
Senior Member

Are you using a version of Eclipse that was released after Java 8 was GA? If not, you should upgrade to the latest version of Eclipse.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Further on Updating the Java version in Eclipse? [message #1772900 is a reply to message #1772892] Mon, 18 September 2017 13:52 Go to previous messageGo to next message
RajibKumar Bandopadhyay is currently offline RajibKumar BandopadhyayFriend
Messages: 58
Registered: July 2014
Member
I can't! I use a pre-built knoppix 7.2.0 that has the Eclipse version I have informed earlier. I will repeat again:
Version: 3.8.0
Build id: I20120502-2000
Re: Further on Updating the Java version in Eclipse? [message #1772917 is a reply to message #1772900] Mon, 18 September 2017 17:09 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3595
Registered: July 2009
Senior Member

That prebuilt version is very much out of date. You can download the current release from download.eclipse.org.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Mon, 18 September 2017 17:11]

Report message to a moderator

Previous Topic:How to remove old versions of Eclipse?
Next Topic:Using variables in config.ini property OSGI.bundles
Goto Forum:
  


Current Time: Sun Feb 23 12:09:33 GMT 2020

Powered by FUDForum. Page generated in 0.05721 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top