Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » Open SWTBot test Recorder with RCP application(SWTBot test Recorder + RCP application doesn't work)
Open SWTBot test Recorder with RCP application [message #1772722] Thu, 14 September 2017 11:10 Go to next message
Antoine Omnès is currently offline Antoine OmnèsFriend
Messages: 11
Registered: September 2017
Junior Member
Hi,

I need your help to use SWTBot Test Recorder with a Eclipse RCP application.

I don't know how to start my RCP application with SWTBot Recorder.

File > New > Other > Run Test Recorder > Run Test Recorder on another application RCP

Configuration:

VM:
-Dorg.eclipse.swtbot.generator.enable=true


Run a product: My app.

Apply.

Run.

===> My application start without SWTBot Test Recorder.

Thanks.
Antoine

PS1: I have already seen this Topic
"https://www.eclipse.org/forums/index.php?t=msg&th=1078197&goto=1734430&#msg_1734430" and It doesn't work for me.
PS2: I can use SWTBot Recorder on Eclipse IDE without any problem.
Re: Open SWTBot test Recorder with RCP application [message #1810488 is a reply to message #1772722] Mon, 12 August 2019 16:37 Go to previous messageGo to next message
Andrea Black is currently offline Andrea BlackFriend
Messages: 3
Registered: May 2019
Junior Member
Hi Antoine. I know it is almost two years later, but I have the exact same problem. Were you able to get the generator to pop up when you run it with your app? Like you, I an run the generator with the Eclipse IDE, but not with my application which was an Eclipse 4 "product". However, I created a sample Eclipse 3 "application" (not product) and it worked just fine. I wonder if anyone has gotten this to work with a "product"?

[Updated on: Mon, 12 August 2019 23:59]

Report message to a moderator

Re: Open SWTBot test Recorder with RCP application [message #1814803 is a reply to message #1810488] Wed, 18 September 2019 17:31 Go to previous messageGo to next message
Andrea Black is currently offline Andrea BlackFriend
Messages: 3
Registered: May 2019
Junior Member
To answer my own question, I gave up in running the generator with a product. The workaround is to launch SWTBot programmatically from within the application under test, which is not ideal.
Re: Open SWTBot test Recorder with RCP application [message #1817445 is a reply to message #1814803] Fri, 22 November 2019 09:50 Go to previous message
Ralf Heydenreich is currently offline Ralf HeydenreichFriend
Messages: 220
Registered: July 2009
Senior Member
Hi all,
I've the same problem. The crazy thing is that it works with an Eclipse 3 application, but not with a new Eclipse 4 one. Don't know if it has to do with that.

Regards,
Ralf.

UPDATE: I've checked it with an E3 and a native E4 application. In E3, the recorder is started, in E4 not.

[Updated on: Mon, 02 December 2019 09:42]

Report message to a moderator

Previous Topic:How to press shortcuts containing numpad keys?
Next Topic:popup menu in NatTable could'nt be found
Goto Forum:
  


Current Time: Fri Jul 10 13:31:58 GMT 2020

Powered by FUDForum. Page generated in 0.02314 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top