Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse SmartHome » Compilation Error(Build Error)
Compilation Error [message #1772686] Wed, 13 September 2017 20:44 Go to next message
levven testing is currently offline levven testingFriend
Messages: 5
Registered: September 2017
Junior Member
Hello,

I am new to java and programming in general.

I am trying to follow the installation guide provided on the official website:

http://www.eclipse.org/smarthome/documentation/development/ide.html

to install the Eclipse SmartHome on a Windows 10 PC. I was able to follow the guide up till step 9. The guide says step 9 should clear all the errors in the project but unfortunately I still have many errors, to be precise the compiler counts them to be 461.
I think I'm doing something wrong but I cannot figure out what that is since I am following every step as is and since I cannot figure out I tried reinstalling it a few times which did not help so I tried on another PC which had a fresh install of windows 10 and I got the same results.

Since this method was failing compilation I tried following the one on GitHub repository using command line:

https://github.com/eclipse/smarthome

Under step 3, Building with Maven after running the command "mvn clean install" after the end of compilation the command line too gave me errors. So I tried running the next command mentioned there "mvn -DskipTests=true clean install" which still gives me errors.

I thought its worth mentioning that I have a few types of recurring errors.

Type one:

Description: Project 'org.eclipse.smarthome.model.item.ide' is missing required source folder: 'src-gen'
Resource: org.eclipse.smarthome.model.item.ide
Path:
Location : Build path
Type: Build Path Problem

Type two:

Description: Package 'org.eclipse.smarthome.model.ide.contentassist.antlr.internal' does not exist in this plug-in
Resource: MANIFEST.MF
Path: /org.eclipse.smarthome.model.item.ide/META-INF
Type: Plug-in Problem

and different types of Java problems which I believe are because the project is not able to find proper libraries and dependencies.

Any idea what I am doing wrong?

Any help much appreciated, Thank you.
Re: Compilation Error [message #1772742 is a reply to message #1772686] Thu, 14 September 2017 15:08 Go to previous messageGo to next message
Henning Treu is currently offline Henning TreuFriend
Messages: 37
Registered: April 2017
Member
Hi,

its not that easy to debug this problem remotely. Please try to execute the "Generate All Models.launch" from the project "org.eclipse.smarthome.model.codegen" and see if that helps.

Cheers,
Henning
Re: Compilation Error [message #1772751 is a reply to message #1772742] Thu, 14 September 2017 17:49 Go to previous messageGo to next message
levven testing is currently offline levven testingFriend
Messages: 5
Registered: September 2017
Junior Member
Hey thank you for your reply. I did try what you asked me. I also googled it and found this link on the same:

https://www.eclipse.org/forums/index.php/t/1083764/
Unfortunately it still didn't work for me. Following are the messages in the Eclipse console window:

0 [main] INFO text.xtext.generator.XtextGenerator - Initializing Xtext generator
12 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Adding generated EPackage 'org.eclipse.xtext.common.types.TypesPackage'
212 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project annotations at 'archive:file:/C:/ESH/eclipse/configuration/org.eclipse.osgi/453/0/.cp/lib/annotations.jar!/' and using 'archive:file:/C:/ESH/ws/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.pde.ds.lib_1.1.0.v20170303-1624/annotations.jar!/' instead.
488 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.item\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
501 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.persistence\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
513 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.rule\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
532 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.script\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
545 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.sitemap\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
560 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.thing\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
567 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.item at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.item/'
567 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.item.ide at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.item.ide/'
568 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.item.ui at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.item.ui/'
577 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Using resourceSet registry. The registered Packages will not be registered in the global EPackage.Registry.INSTANCE!
805 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.eclipse.org/Xtext/Xbase/XAnnotations' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
811 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.eclipse.org/xtext/xbase/Xtype' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
830 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.eclipse.org/xtext/xbase/Xbase' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
830 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.eclipse.org/xtext/common/JavaVMTypes' from 'platform:/resource/org.eclipse.xtext.common.types/model/JavaVMTypes.genmodel'
1605 [main] INFO text.xtext.generator.XtextGenerator - Initializing Xtext generator
1606 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Adding generated EPackage 'org.eclipse.xtext.common.types.TypesPackage'
1612 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project annotations at 'archive:file:/C:/ESH/ws/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.pde.ds.lib_1.1.0.v20170303-1624/annotations.jar!/' and using 'archive:file:/C:/ESH/eclipse/configuration/org.eclipse.osgi/453/0/.cp/lib/annotations.jar!/' instead.
1665 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project annotations at 'archive:file:/C:/ESH/eclipse/configuration/org.eclipse.osgi/453/0/.cp/lib/annotations.jar!/' and using 'archive:file:/C:/ESH/ws/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.pde.ds.lib_1.1.0.v20170303-1624/annotations.jar!/' instead.
1972 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.item\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
1988 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.persistence\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
2002 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.rule\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
2025 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.script\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
2034 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.sitemap\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
2044 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.thing\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
2047 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.sitemap at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.sitemap/'
2048 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.sitemap.ide at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.sitemap.ide/'
2048 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.sitemap.ui at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.sitemap.ui/'
2049 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Using resourceSet registry. The registered Packages will not be registered in the global EPackage.Registry.INSTANCE!
2502 [main] INFO text.xtext.generator.XtextGenerator - Initializing Xtext generator
2502 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Adding generated EPackage 'org.eclipse.xtext.common.types.TypesPackage'
2506 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project annotations at 'archive:file:/C:/ESH/ws/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.pde.ds.lib_1.1.0.v20170303-1624/annotations.jar!/' and using 'archive:file:/C:/ESH/eclipse/configuration/org.eclipse.osgi/453/0/.cp/lib/annotations.jar!/' instead.
2548 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project annotations at 'archive:file:/C:/ESH/eclipse/configuration/org.eclipse.osgi/453/0/.cp/lib/annotations.jar!/' and using 'archive:file:/C:/ESH/ws/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.pde.ds.lib_1.1.0.v20170303-1624/annotations.jar!/' instead.
2843 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.item\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
2855 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.persistence\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
2863 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.rule\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
2881 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.script\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
2891 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.sitemap\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
2901 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.thing\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
2904 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.script at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.script/'
2904 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.script.ide at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.script.ide/'
2905 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.script.ui at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.script.ui/'
2907 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Using resourceSet registry. The registered Packages will not be registered in the global EPackage.Registry.INSTANCE!
3107 [main] INFO text.xtext.generator.XtextGenerator - Initializing Xtext generator
3107 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Adding generated EPackage 'org.eclipse.xtext.common.types.TypesPackage'
3111 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project annotations at 'archive:file:/C:/ESH/ws/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.pde.ds.lib_1.1.0.v20170303-1624/annotations.jar!/' and using 'archive:file:/C:/ESH/eclipse/configuration/org.eclipse.osgi/453/0/.cp/lib/annotations.jar!/' instead.
3159 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project annotations at 'archive:file:/C:/ESH/eclipse/configuration/org.eclipse.osgi/453/0/.cp/lib/annotations.jar!/' and using 'archive:file:/C:/ESH/ws/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.pde.ds.lib_1.1.0.v20170303-1624/annotations.jar!/' instead.
3395 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.item\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
3405 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.persistence\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
3412 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.rule\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
3430 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.script\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
3439 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.sitemap\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
3448 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - No project file found for C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.thing\src. The folder was neither an Eclipse 'bin' folder, nor a Maven 'target/classes' folder.
3449 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.rule at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.rule/'
3449 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.rule.ide at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.rule.ide/'
3450 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.eclipse.smarthome.model.rule.ui at 'file:/C:/ESH/git/smarthome/bundles/model/org.eclipse.smarthome.model.rule.ui/'
3451 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Using resourceSet registry. The registered Packages will not be registered in the global EPackage.Registry.INSTANCE!
3476 [main] ERROR mf.mwe2.launch.runtime.Mwe2Launcher - Problems running workflow all: java.io.FileNotFoundException: C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.script\model\generated\Script.ecore (The system cannot find the path specified)
java.lang.RuntimeException: Problems running workflow all: java.io.FileNotFoundException: C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.script\model\generated\Script.ecore (The system cannot find the path specified)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:104)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:62)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:52)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:78)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:36)
Caused by: org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1DiagnosticWrappedException: java.io.FileNotFoundException: C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.script\model\generated\Script.ecore (The system cannot find the path specified)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDemandLoadException(ResourceSetImpl.java:319)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:278)
at org.eclipse.xtext.resource.XtextResourceSet.getResource(XtextResourceSet.java:265)
at org.eclipse.xtext.xtext.generator.XtextGeneratorResourceSetInitializer.loadResource(XtextGeneratorResourceSetInitializer.java:51)
at org.eclipse.xtext.xtext.generator.XtextGeneratorResourceSetInitializer.lambda$initialize$0(XtextGeneratorResourceSetInitializer.java:41)
at java.util.ArrayList.forEach(ArrayList.java:1249)
at org.eclipse.xtext.xtext.generator.XtextGeneratorResourceSetInitializer.initialize(XtextGeneratorResourceSetInitializer.java:43)
at org.eclipse.xtext.xtext.generator.XtextGeneratorLanguage.initialize(XtextGeneratorLanguage.java:219)
at org.eclipse.xtext.xtext.generator.StandardLanguage.initialize(StandardLanguage.java:175)
at org.eclipse.xtext.xtext.generator.XtextGenerator.initialize(XtextGenerator.java:185)
at org.eclipse.xtext.xtext.generator.XtextGenerator.checkConfigurationInternal(XtextGenerator.java:139)
at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent2.checkConfiguration(AbstractWorkflowComponent2.java:21)
at org.eclipse.emf.mwe.core.lib.Mwe2Bridge.preInvoke(Mwe2Bridge.java:65)
at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.preInvoke(AbstractWorkflowComponent.java:197)
at org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.preInvoke(AbstractCompositeWorkflowComponent.java:29)
at org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.preInvoke(AbstractCompositeWorkflowComponent.java:29)
at org.eclipse.emf.mwe2.runtime.workflow.Workflow.run(Workflow.java:18)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:102)
... 4 more
Caused by: java.io.FileNotFoundException: C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.script\model\generated\Script.ecore (The system cannot find the path specified)
at java.io.FileInputStream.open0(Native Method)
at java.io.FileInputStream.open(FileInputStream.java:195)
at java.io.FileInputStream.<init>(FileInputStream.java:138)
at org.eclipse.emf.ecore.resource.impl.FileURIHandlerImpl.createInputStream(FileURIHandlerImpl.java:99)
at org.eclipse.emf.ecore.resource.impl.ExtensibleURIConverterImpl.createInputStream(ExtensibleURIConverterImpl.java:360)
at org.eclipse.xtext.resource.XtextResourceSet$1.createInputStream(XtextResourceSet.java:298)
at org.eclipse.emf.ecore.resource.impl.PlatformResourceURIHandlerImpl.createInputStream(PlatformResourceURIHandlerImpl.java:532)
at org.eclipse.emf.ecore.resource.impl.ExtensibleURIConverterImpl.createInputStream(ExtensibleURIConverterImpl.java:360)
at org.eclipse.xtext.resource.XtextResourceSet$1.createInputStream(XtextResourceSet.java:298)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1269)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoad(ResourceSetImpl.java:259)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:274)
... 20 more



Seems like the folder
C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.script\model\generated\Script.ecore

is missing. I tried to navigate to the path and it only exists up until
C:\ESH\git\smarthome\bundles\model\org.eclipse.smarthome.model.script\

there is no folder called model\generated\Script.ecore within that path.

Any suggestions?
Thank you again for your time.
Re: Compilation Error [message #1772752 is a reply to message #1772751] Thu, 14 September 2017 17:59 Go to previous messageGo to next message
levven testing is currently offline levven testingFriend
Messages: 5
Registered: September 2017
Junior Member
Also I think if I post the screenshot of the command line error running maven may help, but not sure how do I post images here :/
Anyways the error Im getting when running command "mvn clean install" is

[ INFO ] Eclipse Smart Home Core Tests . . . . . . . . . . . . . . . . . . . . . . FAILURE [ 3.640 s ]

so I googled and found this link which is not of much help either:

https://github.com/eclipse/smarthome/issues/3952

Regards
Re: Compilation Error [message #1772753 is a reply to message #1772751] Thu, 14 September 2017 17:59 Go to previous messageGo to next message
levven testing is currently offline levven testingFriend
Messages: 5
Registered: September 2017
Junior Member
Also I think if I post the screenshot of the command line error running maven may help, but not sure how do I post images here :/
Anyways the error Im getting when running command "mvn clean install" is

[ INFO ] Eclipse Smart Home Core Tests . . . . . . . . . . . . . . . . . . . . . . FAILURE [ 3.640 s ]

so I googled and found this link which is not of much help either:

https://github.com/eclipse/smarthome/issues/3952

Regards
Re: Compilation Error [message #1772767 is a reply to message #1772753] Fri, 15 September 2017 00:29 Go to previous message
levven testing is currently offline levven testingFriend
Messages: 5
Registered: September 2017
Junior Member
Okay so I thought there must be some bug in the new release and downloaded an old .zip release from GitHub (on Jun 13, 2016
ref-0.8.0 ) and tried compiling using the command line maven as instructed on the following link:

https://github.com/eclipse/smarthome

it worked fine for sometime and then the following error popped up:

[ERROR] npm WARN engine bootstrap@3.3.2: wanted: {"node":"~0.10.1"} (current: {"node":"5.4.0","npm":"3.3.12"})
[ERROR] npm WARN deprecated express@2.5.11: express 2.x series is deprecated
[ERROR] npm WARN deprecated connect@1.9.2: connect 1.x series is deprecated
[ERROR] npm WARN install Couldn't install optional dependency: Unsupported
[ERROR] npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
[ERROR] npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
[ERROR] npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
Previous Topic:Help with PaperUI
Next Topic:o.e.s.i.t.m.MqttBrokerConnection.addconsumer() send a wrong wildcard format instead of '+' in Topic
Goto Forum:
  


Current Time: Mon Sep 24 00:32:00 GMT 2018

Powered by FUDForum. Page generated in 0.02633 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top