Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable To Install Eclipse - macOS Sierra(Incompatible JVM)
Unable To Install Eclipse - macOS Sierra [message #1772456] Sun, 10 September 2017 23:53 Go to next message
Michael Cramer is currently offline Michael CramerFriend
Messages: 2
Registered: September 2017
Junior Member
Hi Everybody,

I'm extremely new to Java and about to take an online course that requires me to use Eclipse as our IDE for coding. Unfortunately, I can't seem to install Eclipse on my computer and I'm hoping you guys can help me.

I've read the other forums and posts on sites like stackoverflow.com that told me to make sure I downloaded the 64bit but no matter what mirror I download from I keep getting the same two error messages as I'm trying to open Eclipse (or the installer) on my Mac.

After downloading the 64bit package from the closest mirror to me (Japan) I try to open the eclipse installer and get:
index.php/fa/30685/0/

And after selecting the main eclipse.org download site I try to open the eclipse application and get:
index.php/fa/30687/0/

Here are screenshots from my Java control panel:
index.php/fa/30684/0/
index.php/fa/30686/0/

I've been trying every trick I could find for about a week now and I would really appreciate any help that you guys can give me.
Re: Unable To Install Eclipse - macOS Sierra [message #1772457 is a reply to message #1772456] Mon, 11 September 2017 01:32 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3022
Registered: July 2009
Senior Member

Was that a JRE or a JDK?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Unable To Install Eclipse - macOS Sierra [message #1772459 is a reply to message #1772457] Mon, 11 September 2017 03:57 Go to previous messageGo to next message
Michael Cramer is currently offline Michael CramerFriend
Messages: 2
Registered: September 2017
Junior Member
I downloaded the JRE from the oracle website
Re: Unable To Install Eclipse - macOS Sierra [message #1772462 is a reply to message #1772459] Mon, 11 September 2017 04:59 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3022
Registered: July 2009
Senior Member

You might retry it with a full JDK. Most of the documentation I see is in terms of JDKs specifically. https://developer.apple.com/library/content/qa/qa1170/

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Mon, 11 September 2017 05:02]

Report message to a moderator

Re: Unable To Install Eclipse - macOS Sierra [message #1772591 is a reply to message #1772462] Tue, 12 September 2017 18:05 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3056
Registered: July 2009
Senior Member
Nitin is correct; recent versions of OS X don't treat Java very nicely, and the way to resolve this particular situation is to install the JDK, not the JRE. For Java development, that's desirable anyway since it gives you source code for the core libraries.
Re: Unable To Install Eclipse - macOS Sierra [message #1774600 is a reply to message #1772591] Tue, 17 October 2017 16:35 Go to previous messageGo to next message
rolando gonzalez is currently offline rolando gonzalezFriend
Messages: 1
Registered: October 2017
Junior Member
downloading the jdk is not working, it says version 1.7 required
Re: Unable To Install Eclipse - macOS Sierra [message #1774604 is a reply to message #1774600] Tue, 17 October 2017 17:13 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3022
Registered: July 2009
Senior Member

Which version is not working? Modern versions of Eclipse require JDK 8, and only the absolute latest release, Oxygen.1a, properly supports JDK 9 without some work on your part.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Tue, 17 October 2017 17:15]

Report message to a moderator

Previous Topic:Issues installing WindowBuilder
Next Topic:Eclispe Neon and older > toolbar rearranges icon groups itself after restart
Goto Forum:
  


Current Time: Thu Dec 14 02:16:17 GMT 2017

Powered by FUDForum. Page generated in 0.03237 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software