Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [Teneo] Problem with Enumerated Key in EMap(EMap with Enumerated Key is ignored)
[Teneo] Problem with Enumerated Key in EMap [message #1772402] Fri, 08 September 2017 15:33
Patric Bayer is currently offline Patric BayerFriend
Messages: 3
Registered: September 2015
Junior Member
Hi,

I have several EMaps in my model with Enumerated Keys. There is some commented code in class "OneToManyReferenceAnnotator" which says, that this is intentionally commented as Hibernate does not support Enumerated keys. Therefore, not table is set up for my EMaps and they cannot be persisted.

Any suggestions how to deal with this problem? This is only a problem if I set "EMap as True Map" true, but if I set it false there seem to be a not to little performance issue with the EMaps.

Maybe this is already solved in the current version? On Teneo wiki is a version from 2017, but I cannot find this in the maven repository (there is the last from 2015).

Thank you for your help

Patric

[Updated on: Fri, 08 September 2017 15:35]

Report message to a moderator

Previous Topic:[EMF Forms] Performance Issues with Master-Detail controls (Tree and Table)
Next Topic:Edapt sych on Ecore editor
Goto Forum:
  


Current Time: Thu Sep 20 06:03:07 GMT 2018

Powered by FUDForum. Page generated in 0.01411 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top