Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Problem installing oxygen developer tools
Problem installing oxygen developer tools [message #1771444] Fri, 25 August 2017 06:55 Go to next message
Patrik Nandorf is currently offline Patrik NandorfFriend
Messages: 165
Registered: January 2013
Location: Sweden
Senior Member
hi,

When installing the https://hudson.eclipse.org/papyrus/view/Oxygen/job/Papyrus-Oxygen-Developer/ ontop of https://hudson.eclipse.org/papyrus/view/Oxygen/job/Papyrus-Oxygen/ i get the following error. What am I missing?


Cannot complete the install because one or more required items could not be found.
Software being installed: Papyrus JUnit Framework Feature 2.0.0.201708250246 (org.eclipse.papyrus.junit.feature.feature.group 2.0.0.201708250246)
Missing requirement: Papyrus Extensions to the GMFGen Model Plugin 2.0.0.201708250246 (org.eclipse.papyrus.gmfgenextension 2.0.0.201708250246) requires 'bundle org.eclipse.gmf.codegen [2.11.0,3.0.0)' but it could not be found
Cannot satisfy dependency:
From: Papyrus JUnit Framework Feature 2.0.0.201708250246 (org.eclipse.papyrus.junit.feature.feature.group 2.0.0.201708250246)
To: org.eclipse.papyrus.tests.framework [1.2.0.201708250246]
Cannot satisfy dependency:
From: Papyrus Diagram Test Generation Framework 1.2.0.201708250246 (org.eclipse.papyrus.tests.framework 1.2.0.201708250246)
To: bundle org.eclipse.papyrus.gmfgenextension [2.0.0,3.0.0)
Re: Problem installing oxygen developer tools [message #1771564 is a reply to message #1771444] Mon, 28 August 2017 07:20 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 885
Registered: February 2011
Senior Member
Hi Patrik,

The Papyrus developer tools depend on GMF Tooling, which is no longer part of the Eclipse Release Train in Oxygen. So, you need to add this update site manually:

http://download.eclipse.org/modeling/gmp/gmf-tooling/updates/releases-3.3.1a

Cheers,
Camille


Camille Letavernier
Re: Problem installing oxygen developer tools [message #1771593 is a reply to message #1771564] Mon, 28 August 2017 12:21 Go to previous message
Patrik Nandorf is currently offline Patrik NandorfFriend
Messages: 165
Registered: January 2013
Location: Sweden
Senior Member
Thanks Camille
Previous Topic:Installing Reverse Engineering
Next Topic:GMF based plugin conflict with Papyrus
Goto Forum:
  


Current Time: Wed Sep 19 19:33:13 GMT 2018

Powered by FUDForum. Page generated in 0.01394 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top