Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Kura » Kura on Raspberry PI - Remote management is not working(Deploy-V2 is in unsatisfied state)
Kura on Raspberry PI - Remote management is not working [message #1770235] Wed, 09 August 2017 09:54 Go to next message
Praveen Reddy is currently offline Praveen ReddyFriend
Messages: 14
Registered: June 2017
Junior Member
Hi All,

I installed Kura 3.0 in Raspberry PI device and trying remote management using Deploy-V2.

In that process it is observed that, org.eclipse.kura.core.deployment.ClouddeploymentHandlerV2 is in 'Unsatisfied state'

I checked 'ls', 'ss' and comp on OSGi console.

It is giving error on cloud.CloudService and data.transport.mqtt.MqttDataTransport even, those services are installed and active.

Appreciate your thoughts in resolving this.

Logs are:

All Components:
ID State Component Name Located in bundle
1 Active org.eclipse.equinox.event org.eclipse.equinox.event(bid=8)
2 Active org.eclipse.kura.data.DataService org.eclipse.kura.core(bid=53)
3 Active org.eclipse.kura.db.DbService org.eclipse.kura.core(bid=53)
4 Active org.eclipse.kura.core.data.transport.mqtt.MqttDataTransport org.eclipse.kura.core(bid=53)
5 Active org.eclipse.kura.ssl.SslManagerService org.eclipse.kura.core(bid=53)
6 Active org.eclipse.kura.system.SystemService org.eclipse.kura.core(bid=53)
7 Active org.eclipse.kura.system.SystemAdminService org.eclipse.kura.core(bid=53)
8 Active org.eclipse.kura.certificate.CertificatesService org.eclipse.kura.core.certificates(bid=54)
9 Active org.eclipse.kura.cloud.CloudService org.eclipse.kura.core.cloud(bid=55)
10 Registered org.eclipse.kura.cloud.CloudCallService org.eclipse.kura.core.cloud(bid=55)
11 Active org.eclipse.kura.core.cloud.factory.DefaultCloudServiceFactory org.eclipse.kura.core.cloud(bid=55)
12 Unsatisfied org.eclipse.kura.cloud.app.command.CommandCloudApp org.eclipse.kura.core.cloud(bid=55)
13 Active org.eclipse.kura.core.comm.CommConnectionFactory org.eclipse.kura.core.comm(bid=56)
14 Active org.eclipse.kura.core.configuration.CloudConfigurationHandler org.eclipse.kura.core.configuration(bid=57)
15 Active org.eclipse.kura.configuration.ConfigurationService org.eclipse.kura.core.configuration(bid=57)
16 Active org.eclipse.kura.crypto.CryptoService org.eclipse.kura.core.crypto(bid=58)
17 Unsatisfied org.eclipse.kura.core.deployment.CloudDeploymentHandlerV2 org.eclipse.kura.core.deployment(bid=59)
18 Active org.eclipse.kura.log.LoggerService org.eclipse.kura.core.log(bid=60)
19 Active org.eclipse.kura.status.CloudConnectionStatusService org.eclipse.kura.core.status(bid=62)
20 Active org.eclipse.kura.deployment.agent org.eclipse.kura.deployment.agent(bid=63)

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Dynamic information :
*The component is NOT satisfied
The following references are not satisfied:
Reference[name = CloudService, interface = org.eclipse.kura.cloud.CloudService, policy = static, cardinality = 1..1, target = (kura.service.pid=org.eclipse.kura.cloud.CloudService), bind = setCloudService, unbind = unsetCloudService]
Reference[name = DataTransportService, interface = org.eclipse.kura.data.DataTransportService, policy = static, cardinality = 1..1, target = (kura.service.pid=org.eclipse.kura.core.data.transport.mqtt.MqttDataTransport), bind = setDataTransportService, unbind = unsetDataTransportService]
Component configurations :
Configuration properties:
CloudService.target = (kura.service.pid=org.eclipse.kura.cloud.CloudService)
component.name = org.eclipse.kura.core.deployment.CloudDeploymentHandlerV2
DataTransportService.target = (kura.service.pid=org.eclipse.kura.core.data.transport.mqtt.MqttDataTransport)
component.id = 34
Instances:



Thank you.

With Best Regards,
Praveen.B
Re: Kura on Raspberry PI - Remote management is not working [message #1770236 is a reply to message #1770235] Wed, 09 August 2017 09:56 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 279
Registered: July 2015
Location: Italy
Senior Member
Hi,
could you post a screenshot of the current cloud service instances you have?

Best regards,
Matteo
Re: Kura on Raspberry PI - Remote management is not working [message #1770288 is a reply to message #1770236] Wed, 09 August 2017 16:25 Go to previous messageGo to next message
Praveen Reddy is currently offline Praveen ReddyFriend
Messages: 14
Registered: June 2017
Junior Member
Hi Matteo,

I configured two cloud services. One with Azure IoT Hub and another with IoT.Eclipse. Both connections are established properly.

Please find attached screenshot.

WIth Best Regards,
Praveen.B
  • Attachment: kuraerror.png
    (Size: 167.11KB, Downloaded 56 times)
Re: Kura on Raspberry PI - Remote management is not working [message #1770299 is a reply to message #1770288] Wed, 09 August 2017 18:26 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 279
Registered: July 2015
Location: Italy
Senior Member
Hi,
that's the point: the deployV2 is strictly related to the default cloud service.
Here the reference that should be matched: CloudService.target = (kura.service.pid=org.eclipse.kura.cloud.CloudService)

Best regards
Re: Kura on Raspberry PI - Remote management is not working [message #1770328 is a reply to message #1770236] Thu, 10 August 2017 04:14 Go to previous message
Praveen Reddy is currently offline Praveen ReddyFriend
Messages: 14
Registered: June 2017
Junior Member
Hi Matteo,

Thank you for the hint, I could solve the problem.

With Best Regards,
Praveen.B


[Updated on: Thu, 10 August 2017 18:27]

Report message to a moderator

Previous Topic:Kura Services OsGI-Inf Metatype xml Editing
Next Topic:Kura with Kapua
Goto Forum:
  


Current Time: Wed Nov 14 17:48:42 GMT 2018

Powered by FUDForum. Page generated in 0.02291 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top