Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Kura » Problem in setting up the Kura Development Environment
Problem in setting up the Kura Development Environment [message #1770006] Mon, 07 August 2017 13:26 Go to next message
Thong Nguyen is currently offline Thong NguyenFriend
Messages: 4
Registered: May 2017
Junior Member
Hi, I have some trouble following the getting started guide [1]. When using Eclipse IDE (Oxygen) to import Kura user workspace, I cannot click the link "Set as target platform", the file "kura-equinox.target" just appear as a text file like following when I double click on it:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde version="3.8"?>

<target name="Kura Target Platform Equinox 3.11.1" sequenceNumber="43">
  <locations>
    <location path="${workspace_loc}/target-definition/equinox_3.11.1/repository/plugins" type="Profile"/>
	<location path="${workspace_loc}/target-definition/common/repository/plugins" type="Profile"/>
  </locations>
</target>]


I also tried using Oomph installer, but when Eclipse IDE startup and begins to check out the code I received alot of errors related to Auth Failed like this (I am using Linux, not Windows):

java.lang.Exception: org.eclipse.jgit.api.errors.TransportException: git@github.com:eclipse/kura.git: Auth fail
  at org.eclipse.oomph.setup.git.impl.GitCloneTaskImpl.perform(GitCloneTaskImpl.java:881)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3324)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:3267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4494)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4488)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4486)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3258)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3233)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3133)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:567)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:693)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56)
Caused by: org.eclipse.jgit.api.errors.TransportException: git@github.com:eclipse/kura.git: Auth fail
  at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:245)
  at org.eclipse.jgit.api.CloneCommand.fetch(CloneCommand.java:293)
  at org.eclipse.jgit.api.CloneCommand.call(CloneCommand.java:190)
  at org.eclipse.oomph.setup.git.impl.GitCloneTaskImpl.cloneRepository(GitCloneTaskImpl.java:942)
  at org.eclipse.oomph.setup.git.impl.GitCloneTaskImpl.perform(GitCloneTaskImpl.java:805)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3324)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:3267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4494)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4488)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4486)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3258)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3233)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3133)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:567)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:693)
  ... 1 more



[1]: https://eclipse.github.io/kura/dev/kura-setup.html

Re: Problem in setting up the Kura Development Environment [message #1770008 is a reply to message #1770006] Mon, 07 August 2017 13:48 Go to previous messageGo to next message
Thong Nguyen is currently offline Thong NguyenFriend
Messages: 4
Registered: May 2017
Junior Member
I changed the IDE to Eclipse EE and it worked :)
Re: Problem in setting up the Kura Development Environment [message #1770009 is a reply to message #1770006] Mon, 07 August 2017 13:49 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 279
Registered: July 2015
Location: Italy
Senior Member
Hi,
in the Oomph setup, I would suggest you to change the ssh reference to the HTTPS one: https://github.com/eclipse/kura.git

Best regards,
Matteo
Re: Problem in setting up the Kura Development Environment [message #1770034 is a reply to message #1770009] Mon, 07 August 2017 16:04 Go to previous messageGo to next message
Thong Nguyen is currently offline Thong NguyenFriend
Messages: 4
Registered: May 2017
Junior Member
Hi,

I am following the getting started guide with kura version 2.0. When trying to run the emulator I got these messages in the console:

!SESSION 2017-08-07 17:58:53.957 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_131
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -dev file:/home/cloud/kura-workspace/.metadata/.plugins/org.eclipse.pde.core/Kura_Emulator_Linux/dev.properties -os linux -ws gtk -arch x86_64 -consoleLog -console

!ENTRY org.eclipse.kura.demo.heater 4 0 2017-08-07 17:58:54.807
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.kura.demo.heater_1.0.2.qualifier [1]" could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.kura.cloud; version="[1.0.0,2.0.0)"
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.kura.example.beacon 4 0 2017-08-07 17:58:54.988
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.kura.example.beacon_1.0.1 [21]" could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.kura.bluetooth; version="[1.0.0,2.0.0)"
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.kura.example.publisher 4 0 2017-08-07 17:58:54.989
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.kura.example.publisher_1.0.2.qualifier [24]" could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.kura; version="[1.0.0,2.0.0)"
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
osgi> 17:58:55,116 [Component Resolve Thread] INFO  HelloOsgi:15  - Bundle org.eclipse.kura.example.hello_osgi has started!

!ENTRY org.eclipse.kura.example.ble.tisensortag 4 0 2017-08-07 17:58:55.141
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.kura.example.ble.tisensortag_1.0.2 [44]" could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.kura; version="[1.0.0,2.0.0)"
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
17:58:55,194 [Start Level Event Dispatcher] INFO  Server:253  - jetty-8.1.3.v20120522
17:58:55,254 [Start Level Event Dispatcher] WARN  AbstractLifeCycle:199  - FAILED SelectChannelConnector@0.0.0.0:8080: java.net.BindException: Address already in use
java.net.BindException: Address already in use
	at sun.nio.ch.Net.bind0(Native Method)
	at sun.nio.ch.Net.bind(Net.java:433)
	at sun.nio.ch.Net.bind(Net.java:425)
	at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
	at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
	at org.eclipse.jetty.server.nio.SelectChannelConnector.open(SelectChannelConnector.java:182)
	at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:311)
	at org.eclipse.jetty.server.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:260)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
	at org.eclipse.jetty.server.Server.doStart(Server.java:273)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
	at org.eclipse.equinox.http.jetty.internal.HttpServerManager.updated(HttpServerManager.java:113)
	at org.eclipse.equinox.http.jetty.internal.Activator.start(Activator.java:62)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
17:58:55,256 [Start Level Event Dispatcher] WARN  AbstractLifeCycle:199  - FAILED org.eclipse.jetty.server.Server@1681e420: java.net.BindException: Address already in use
java.net.BindException: Address already in use
	at sun.nio.ch.Net.bind0(Native Method)
	at sun.nio.ch.Net.bind(Net.java:433)
	at sun.nio.ch.Net.bind(Net.java:425)
	at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
	at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
	at org.eclipse.jetty.server.nio.SelectChannelConnector.open(SelectChannelConnector.java:182)
	at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:311)
	at org.eclipse.jetty.server.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:260)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
	at org.eclipse.jetty.server.Server.doStart(Server.java:273)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
	at org.eclipse.equinox.http.jetty.internal.HttpServerManager.updated(HttpServerManager.java:113)
	at org.eclipse.equinox.http.jetty.internal.Activator.start(Activator.java:62)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.equinox.http.jetty 4 0 2017-08-07 17:58:55.256
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.equinox.http.jetty.internal.Activator.start() of bundle org.eclipse.equinox.http.jetty.
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
Caused by: org.osgi.service.cm.ConfigurationException: default : Address already in use
	at org.eclipse.equinox.http.jetty.internal.HttpServerManager.updated(HttpServerManager.java:115)
	at org.eclipse.equinox.http.jetty.internal.Activator.start(Activator.java:62)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
	... 12 more
Caused by: java.net.BindException: Address already in use
	at sun.nio.ch.Net.bind0(Native Method)
	at sun.nio.ch.Net.bind(Net.java:433)
	at sun.nio.ch.Net.bind(Net.java:425)
	at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
	at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
	at org.eclipse.jetty.server.nio.SelectChannelConnector.open(SelectChannelConnector.java:182)
	at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:311)
	at org.eclipse.jetty.server.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:260)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
	at org.eclipse.jetty.server.Server.doStart(Server.java:273)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
	at org.eclipse.equinox.http.jetty.internal.HttpServerManager.updated(HttpServerManager.java:113)
	... 16 more
Root exception:
org.osgi.service.cm.ConfigurationException: default : Address already in use
	at org.eclipse.equinox.http.jetty.internal.HttpServerManager.updated(HttpServerManager.java:115)
	at org.eclipse.equinox.http.jetty.internal.Activator.start(Activator.java:62)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
	at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
	at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
Caused by: java.net.BindException: Address already in use
	at sun.nio.ch.Net.bind0(Native Method)
	at sun.nio.ch.Net.bind(Net.java:433)
	at sun.nio.ch.Net.bind(Net.java:425)
	at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
	at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
	at org.eclipse.jetty.server.nio.SelectChannelConnector.open(SelectChannelConnector.java:182)
	at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:311)
	at org.eclipse.jetty.server.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:260)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
	at org.eclipse.jetty.server.Server.doStart(Server.java:273)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:59)
	at org.eclipse.equinox.http.jetty.internal.HttpServerManager.updated(HttpServerManager.java:113)
	... 16 more

!ENTRY org.eclipse.osgi 4 0 2017-08-07 17:58:55.259
!MESSAGE Bundle initial@reference:file:../../../../org.eclipse.kura.demo.heater/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2017-08-07 17:58:55.259
!MESSAGE Bundle initial@reference:file:../../../../org.eclipse.kura.example.beacon/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2017-08-07 17:58:55.260
!MESSAGE Bundle initial@reference:file:../../../../org.eclipse.kura.example.publisher/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2017-08-07 17:58:55.260
!MESSAGE Bundle initial@reference:file:../../../../org.eclipse.kura.example.ble.tisensortag/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2017-08-07 17:58:55.260
!MESSAGE Bundle org.eclipse.equinox.http.jetty_3.0.0.v20120522-1841 [47] is not active.

!ENTRY org.eclipse.osgi 2 0 2017-08-07 17:58:55.285
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-08-07 17:58:55.285
!MESSAGE Bundle initial@reference:file:../../../../org.eclipse.kura.demo.heater/ was not resolved.
!SUBENTRY 2 org.eclipse.kura.demo.heater 2 0 2017-08-07 17:58:55.285
!MESSAGE Missing imported package org.eclipse.kura.cloud_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.demo.heater 2 0 2017-08-07 17:58:55.285
!MESSAGE Missing imported package org.eclipse.kura.configuration_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.demo.heater 2 0 2017-08-07 17:58:55.285
!MESSAGE Missing imported package org.eclipse.kura.message_[1.0.0,2.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-08-07 17:58:55.286
!MESSAGE Bundle initial@reference:file:../../../../org.eclipse.kura.example.ble.tisensortag/ was not resolved.
!SUBENTRY 2 org.eclipse.kura.example.ble.tisensortag 2 0 2017-08-07 17:58:55.286
!MESSAGE Missing imported package org.eclipse.kura_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.ble.tisensortag 2 0 2017-08-07 17:58:55.286
!MESSAGE Missing imported package org.eclipse.kura.cloud_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.ble.tisensortag 2 0 2017-08-07 17:58:55.286
!MESSAGE Missing imported package org.eclipse.kura.message_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.ble.tisensortag 2 0 2017-08-07 17:58:55.287
!MESSAGE Missing imported package org.eclipse.kura.bluetooth_[1.1.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.ble.tisensortag 2 0 2017-08-07 17:58:55.287
!MESSAGE Missing imported package org.eclipse.kura.configuration_[1.0.0,2.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-08-07 17:58:55.287
!MESSAGE Bundle initial@reference:file:../../../../org.eclipse.kura.example.publisher/ was not resolved.
!SUBENTRY 2 org.eclipse.kura.example.publisher 2 0 2017-08-07 17:58:55.287
!MESSAGE Missing imported package org.eclipse.kura_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.publisher 2 0 2017-08-07 17:58:55.287
!MESSAGE Missing imported package org.eclipse.kura.cloud_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.publisher 2 0 2017-08-07 17:58:55.287
!MESSAGE Missing imported package org.eclipse.kura.configuration_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.publisher 2 0 2017-08-07 17:58:55.288
!MESSAGE Missing imported package org.eclipse.kura.message_[1.0.0,2.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-08-07 17:58:55.288
!MESSAGE Bundle initial@reference:file:../../../../org.eclipse.kura.example.beacon/ was not resolved.
!SUBENTRY 2 org.eclipse.kura.example.beacon 2 0 2017-08-07 17:58:55.288
!MESSAGE Missing imported package org.eclipse.kura.bluetooth_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.beacon 2 0 2017-08-07 17:58:55.288
!MESSAGE Missing imported package org.eclipse.kura.configuration_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.beacon 2 0 2017-08-07 17:58:55.288
!MESSAGE Missing imported package org.eclipse.kura.message_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.beacon 2 0 2017-08-07 17:58:55.288
!MESSAGE Missing imported package org.eclipse.kura.cloud_[1.0.0,2.0.0).

!ENTRY org.eclipse.osgi 2 0 2017-08-07 17:58:55.297
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-08-07 17:58:55.297
!MESSAGE Bundle org.eclipse.kura.demo.heater_1.0.2.qualifier [1] was not resolved.
!SUBENTRY 2 org.eclipse.kura.demo.heater 2 0 2017-08-07 17:58:55.297
!MESSAGE Missing imported package org.eclipse.kura.cloud_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.demo.heater 2 0 2017-08-07 17:58:55.298
!MESSAGE Missing imported package org.eclipse.kura.configuration_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.demo.heater 2 0 2017-08-07 17:58:55.298
!MESSAGE Missing imported package org.eclipse.kura.message_[1.0.0,2.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-08-07 17:58:55.298
!MESSAGE Bundle org.eclipse.kura.example.beacon_1.0.1 [21] was not resolved.
!SUBENTRY 2 org.eclipse.kura.example.beacon 2 0 2017-08-07 17:58:55.298
!MESSAGE Missing imported package org.eclipse.kura.bluetooth_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.beacon 2 0 2017-08-07 17:58:55.298
!MESSAGE Missing imported package org.eclipse.kura.cloud_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.beacon 2 0 2017-08-07 17:58:55.298
!MESSAGE Missing imported package org.eclipse.kura.configuration_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.beacon 2 0 2017-08-07 17:58:55.298
!MESSAGE Missing imported package org.eclipse.kura.message_[1.0.0,2.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-08-07 17:58:55.298
!MESSAGE Bundle org.eclipse.kura.example.publisher_1.0.2.qualifier [24] was not resolved.
!SUBENTRY 2 org.eclipse.kura.example.publisher 2 0 2017-08-07 17:58:55.298
!MESSAGE Missing imported package org.eclipse.kura_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.publisher 2 0 2017-08-07 17:58:55.298
!MESSAGE Missing imported package org.eclipse.kura.cloud_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.publisher 2 0 2017-08-07 17:58:55.298
!MESSAGE Missing imported package org.eclipse.kura.configuration_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.publisher 2 0 2017-08-07 17:58:55.298
!MESSAGE Missing imported package org.eclipse.kura.message_[1.0.0,2.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-08-07 17:58:55.298
!MESSAGE Bundle org.eclipse.kura.example.ble.tisensortag_1.0.2 [44] was not resolved.
!SUBENTRY 2 org.eclipse.kura.example.ble.tisensortag 2 0 2017-08-07 17:58:55.299
!MESSAGE Missing imported package org.eclipse.kura_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.ble.tisensortag 2 0 2017-08-07 17:58:55.299
!MESSAGE Missing imported package org.eclipse.kura.bluetooth_[1.1.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.ble.tisensortag 2 0 2017-08-07 17:58:55.299
!MESSAGE Missing imported package org.eclipse.kura.cloud_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.ble.tisensortag 2 0 2017-08-07 17:58:55.299
!MESSAGE Missing imported package org.eclipse.kura.configuration_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.kura.example.ble.tisensortag 2 0 2017-08-07 17:58:55.299
!MESSAGE Missing imported package org.eclipse.kura.message_[1.0.0,2.0.0).


Any idea on how to resolve these messages ? Thank you alot.

Re: Problem in setting up the Kura Development Environment [message #1770041 is a reply to message #1770034] Mon, 07 August 2017 17:16 Go to previous message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 279
Registered: July 2015
Location: Italy
Senior Member
Hi,
I see few problems here: first of all, it seems that the launch configuration has some dependencies not selected.
Other than that, it seems that the port 8080 is already in use. Is it possible that you have multiple emulator instances running at the same time?

Best regards
Previous Topic:Metatype configuration supported data types - tables/lists?
Next Topic:ClouddeploymentHandlerV2 in unsatisfied state
Goto Forum:
  


Current Time: Mon Nov 12 22:23:10 GMT 2018

Powered by FUDForum. Page generated in 0.02711 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top