Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse SmartHome » Build error(Eclipse smarthome Build error )
Build error [message #1769730] Thu, 03 August 2017 01:21 Go to next message
jaya ala is currently offline jaya alaFriend
Messages: 7
Registered: August 2017
Junior Member
I am new to eclipse smarthome code . I am seeing following error when i tried to do mvn -DskipTests=true clean install

[ERROR] Failed to resolve target definition C:\software\smarthome-master\targetplatform\ Failed to load p2 metadata repository from location /2.2.0: No repository found at /update-site/2.2.0. -> [Help 1]

Can anyone help me to solve this. It looks like issue with P2 to me. But not sure how i can solve it.

Any help is appreciated.


Re: Build error [message #1769772 is a reply to message #1769730] Thu, 03 August 2017 09:47 Go to previous message
Kai Kreuzer is currently offline Kai KreuzerFriend
Messages: 641
Registered: December 2011
Senior Member
Hi Jaya,

This sounds like a temporary problem on your end - at the given location, there definitely is a p2 repository and the build works fine on our CI server as well as locally for me.
So please try again, it should work!

Previous Topic:Best way to implement Discovery without known thingtype
Next Topic:Build fails on Win10/x64 with Maven 3.50
Goto Forum:

Current Time: Thu Mar 22 08:11:33 GMT 2018

Powered by FUDForum. Page generated in 0.02133 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software