Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to install Eclipse Oxygen on macOS Sierra due to JRE 6 dependency(Java 8 JRE is not a suitable prerequisite for the Eclipse installer)
Unable to install Eclipse Oxygen on macOS Sierra due to JRE 6 dependency [message #1769484] Tue, 01 August 2017 03:16 Go to next message
David Antliff is currently offline David AntliffFriend
Messages: 10
Registered: April 2015
Junior Member
I'm trying to install the latest Eclipse Oxygen release (eclipse-inst-mac64.tar.gz downloaded today) onto macOS 10.12.5 (Sierra). After decompressing the tarball, I have a "Eclipse Installer.app" that when I open gives me this error:

"To open "Eclipse-inst" you need to install the legacy Java SE 6 runtime."

However, according to this page, I should only need JRE 8, not JRE 6.

I have downloaded JRE SE 8u144 from Oracle and installed it, however I still get this error message.

Is it actually correct? Do I really need two different JREs installed to install Eclipse? Why doesn't the installer work with JRE 8?

EDIT: I have confirmed via Safari and oracle.com that v8u144 is "active" on my system.

EDIT: I see on StackOverflow that the problem might be solved by installing JDK 8 rather than JRE. However I specifically do not with to do this (I will be using Eclipse with CDT, not for Java development) and if it truly is a requirement then I suggest two changes:

1. fix the installer so it works with a modern version of the Java RE.
2. update the docs so that it specifies the JDK as a minimum requirement, rather than the JRE.

[Updated on: Tue, 01 August 2017 03:24]

Report message to a moderator

Re: Unable to install Eclipse Oxygen on macOS Sierra due to JRE 6 dependency [message #1769498 is a reply to message #1769484] Tue, 01 August 2017 05:03 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29589
Registered: July 2009
Senior Member
Unfortunately each OS has its own peculiarities. The message about needing Java 6 comes from the Mac OS itself, and it's a bogus message. This basic problem affects not just the installer application, but any other Eclipse application you will try to install using it, because the installer application is in fact just an Eclipse application and will suffer from all the same problems that it has. So yes, as far as I understand it, to run any Eclipse application on a Mac, you will need to install a JDK, best a JDK 8 at this point. Not that it's helpful to you, but for Windows, the installer is distributed as a native executable that does smarter checking of the available JREs and JDKs on the system so it does a better job detecting problems you will have when you actually try to launch the application, linking you to a page like this: http://download.eclipse.org/oomph/jre/?vm=2 filtered to the version that's needed when the right JRE/JDK is not available.

Certainly there isn't much useful to explain this Mac-specific peculiarity at https://wiki.eclipse.org/Eclipse/Installation nor in https://www.eclipse.org/downloads/eclipse-packages/?show_instructions=TRUE but I wonder if that's the documentation you think would be best to update, or were you looking elsewhere?

Re: Unable to install Eclipse Oxygen on macOS Sierra due to JRE 6 dependency [message #1769731 is a reply to message #1769498] Thu, 03 August 2017 01:46 Go to previous messageGo to next message
David Antliff is currently offline David AntliffFriend
Messages: 10
Registered: April 2015
Junior Member
Thanks for the response. I'll install the JDK. The documentation I mentioned was linked in my first post: "A Java 8 JRE/JDK is required to run all Oxygen packages based on Eclipse 4.7" - perhaps it should include a note to say "JDK" for macOS?
Re: Unable to install Eclipse Oxygen on macOS Sierra due to JRE 6 dependency [message #1769738 is a reply to message #1769731] Thu, 03 August 2017 05:15 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29589
Registered: July 2009
Senior Member
Sorry, I should have noticed that. I've made a number of changes to the wiki to make the Mac issues explicit.
Re: Unable to install Eclipse Oxygen on macOS Sierra due to JRE 6 dependency [message #1795119 is a reply to message #1769738] Sat, 15 September 2018 08:06 Go to previous messageGo to next message
john smith is currently offline john smithFriend
Messages: 1
Registered: September 2018
Location: usa
Junior Member
Hey, I have faced the same situation whereas already I'm trying to install the latest Eclipse Oxygen release, but I was not able to install this because I haven't get the latest update of IOS version then I decide to visit the apple support site but iPhone Support expert team don't provide me any solution their executive told me that they don't have any idea about Eclipse Oxygen.
Re: Unable to install Eclipse Oxygen on macOS Sierra due to JRE 6 dependency [message #1795132 is a reply to message #1795119] Sun, 16 September 2018 04:36 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29589
Registered: July 2009
Senior Member
On the Mac you must install a full JDK. Did you actually install a Java 8 (o higher) JDK (not just a JRE)?
Previous Topic:eclipse not recognising characters such as "++" or ","
Next Topic:Project missing .project/ Wrong project location
Goto Forum:
  


Current Time: Mon Oct 15 19:01:46 GMT 2018

Powered by FUDForum. Page generated in 0.03589 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top