Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Problem opening profile models created in previous version of Papyrus
Problem opening profile models created in previous version of Papyrus [message #1769078] Wed, 26 July 2017 10:06 Go to next message
Missing name Mising name is currently offline Missing name Mising nameFriend
Messages: 5
Registered: September 2011
Junior Member
When using Papyrus Oxygen 3.0 to open a UML profile model created in Neon.1 (Papyrus 2.0.1) I get the following problems:

- The existing profile diagrams are not recognized as valid diagram types (they are displayed with an "error" icon on the model explorer and in the "Notation View")
- No palette is provided after opening the existing diagram
- "Profile Diagram" is not provided as an option in the New Diagrams popup

It would appear as if Papyrus 3.0 does not recognize the models as profile models.

Is there a migration process that needs to be performed to bring existing profile models into Papyrus 3.0 ?
Re: Problem opening profile models created in previous version of Papyrus [message #1769087 is a reply to message #1769078] Wed, 26 July 2017 11:52 Go to previous message
Benoit Maggi is currently offline Benoit MaggiFriend
Messages: 107
Registered: March 2013
Location: Bordeaux, France
Senior Member
This is a known issue
https://bugs.eclipse.org/bugs/show_bug.cgi?id=518691

Changing the context should solve that:
- right click on model explorer
- switch context
- chose profile
Previous Topic:CSS to hide empty compartments on class diagrams
Next Topic:Can't change default sysml Block preferences
Goto Forum:
  


Current Time: Wed Jan 17 01:50:30 GMT 2018

Powered by FUDForum. Page generated in 0.01868 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software