Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » RCP Project Project Explorer - Unable to create class CompatibilityView(!MESSAGE Unable to create class 'org.eclipse.ui.internal.e4.compatibility.CompatibilityView' from bundle '86')
RCP Project Project Explorer - Unable to create class CompatibilityView [message #1768178] Fri, 14 July 2017 11:31 Go to next message
M V is currently offline M VFriend
Messages: 31
Registered: July 2017
Member
Hallo,

i'am new in Eclipse RCP. I try to build an RCP project on base of E4 with the default project explorer. I found this two tutorials: dirksmetric.wordpress.com/2012/08/01/tutorial-eclipse-rcp-e4-with-3-x-views-like-project-explorer-properties-etc/ vogella.com/tutorials/Eclipse4MigrationGuide/article.html

After all i have an window with parts but the project explorer is not loaded. This is the stackstrace from log.

!ENTRY org.eclipse.e4.ui.workbench 4 0 2017-07-14 12:11:32.706
!MESSAGE Unable to create class 'org.eclipse.ui.internal.e4.compatibility.CompatibilityView' from bundle '86'
!STACK 0
org.eclipse.e4.core.di.InjectionException: Could not find satisfiable constructor in org.eclipse.ui.internal.e4.compatibility.CompatibilityView
	at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:408)
	at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:318)
	at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162)
	at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.createFromBundle(ReflectionContributionFactory.java:105)
	at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.doCreate(ReflectionContributionFactory.java:74)
	at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.create(ReflectionContributionFactory.java:56)
	at org.eclipse.e4.ui.workbench.renderers.swt.ContributedPartRenderer.createWidget(ContributedPartRenderer.java:129)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createWidget(PartRenderingEngine.java:997)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.safeCreateGui(PartRenderingEngine.java:666)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$1.run(PartRenderingEngine.java:551)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createGui(PartRenderingEngine.java:535)
	at org.eclipse.e4.ui.workbench.renderers.swt.ElementReferenceRenderer.createWidget(ElementReferenceRenderer.java:70)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createWidget(PartRenderingEngine.java:997)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.safeCreateGui(PartRenderingEngine.java:666)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.safeCreateGui(PartRenderingEngine.java:772)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.access$0(PartRenderingEngine.java:743)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$2.run(PartRenderingEngine.java:737)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createGui(PartRenderingEngine.java:721)
	at org.eclipse.e4.ui.workbench.renderers.swt.StackRenderer.showTab(StackRenderer.java:1289)
	at org.eclipse.e4.ui.workbench.renderers.swt.LazyStackRenderer.lambda$0(LazyStackRenderer.java:68)
	at org.eclipse.e4.ui.services.internal.events.UIEventHandler$1.run(UIEventHandler.java:40)
	at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:233)
	at org.eclipse.swt.widgets.Display.syncExec(Display.java:5439)


this ist my plugin.xml
<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.4"?>
<plugin>
   <extension
		id="product_spside"
		point="org.eclipse.core.runtime.products"> <!-- org.eclipse.core.runtime.applications -->
		
		<product application="org.eclipse.e4.ui.workbench.swt.E4Application" name="SPS IDE">
		<!-- org.eclipse.e4.ui.workbench.swt.E4Application -->    
    	<property name="appName" value="SPS IDE"> </property>
    	<property name="applicationXMI" value="spside.rcp/Application.e4xmi"> </property>
	</product>
      <!-- <application>
		<run
			class="spside.rcp.Application">
		</run>
   	</application>-->   
   </extension>
    <!-- <extension point="org.eclipse.ui.perspectives">
		<perspective
            name="RCP Perspective"
            class="spside.rcp.Perspective"
            id="spside.rcp.perspective">
      </perspective>
   </extension>-->   
</plugin>


I try all tipps from google but i have no idea what to do.

thanks for help!
Re: RCP Project Project Explorer - Unable to create class CompatibilityView [message #1768804 is a reply to message #1768178] Mon, 24 July 2017 05:38 Go to previous message
M V is currently offline M VFriend
Messages: 31
Registered: July 2017
Member
I resolve the problem by my self. I make a new RCP project from the scratch of like in this tutorial: https://dirksmetric.wordpress.com/2012/08/01/tutorial-eclipse-rcp-e4-with-3-x-views-like-project-explorer-properties-etc/ an it works. After this, I realize that my pom.xml of the original project looks different to the new one.

<?xml version="1.0" encoding="UTF-8"?>
<?eclipse version="3.4"?>
<plugin>

   <extension
         id="application"
         point="org.eclipse.core.runtime.applications">
      <application>
         <run
               class="spside.rcp.Application">
         </run>
      </application>
   </extension>
   <extension
         point="org.eclipse.ui.perspectives">
      <perspective
            name="Perspective"
            class="spside.rcp.Perspective"
            id="spside.rcp.perspective">
      </perspective>
   </extension>
   <extension
         point="org.eclipse.ui.views">
      <view
            name="View"
            inject="true"
            class="spside.rcp.View"
            id="spside.rcp.view">
      </view>
   </extension>
   <extension
         point="org.eclipse.ui.perspectiveExtensions">
      <perspectiveExtension
            targetID="*">
         <view
               standalone="true"
               minimized="false"
               relative="org.eclipse.ui.editorss"
               relationship="left"
               id="spside.rcp.view">
         </view>
      </perspectiveExtension>
   </extension>
   <extension
         point="org.eclipse.ui.menus">
      <menuContribution
            locationURI="menu:org.eclipse.ui.main.menu">
         <menu
               label="File">
            <command
                  commandId="org.eclipse.ui.file.exit"
                  label="Exit">
            </command>
         </menu>
      </menuContribution>
   </extension>
<extension id="product_test" point="org.eclipse.core.runtime.products">
  <product application="spside.rcp.application" name="My Product">
    <property name="appName" value="SPS IDE"> </property>
    <property name="applicationXMI" value="spside.rcp/Application.e4xmi"> </property>
  </product>
</extension>
</plugin>


I think the main problem was, that I not initialised the 3.x Components in the first extension. The next problem was that the second extension point must target to the same id: id="spside.rcp.perspective" as in the Application.e4xmi.
Previous Topic:How to left/right align toolitems in toolbar?
Next Topic:Strange nested part stack behavior when minimize button is pressed
Goto Forum:
  


Current Time: Sun Nov 18 11:12:34 GMT 2018

Powered by FUDForum. Page generated in 0.02436 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top