Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Updating software error(Repository not found error)
Updating software error [message #1767848] Tue, 11 July 2017 14:43 Go to next message
Nathan truhan is currently offline Nathan truhanFriend
Messages: 3
Registered: July 2017
Junior Member
I know these come up often, but I can't seem to find an answer elsewhere so I thought I would post.

I upgraded Neon.3 to Oxygen and everything seemed to go ok. I updated all my repositories to newer releases that I could find; however, I am still getting the following:

An error occurred while collecting items to be installed
session context was:(profile=D__eclipse_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.codehaus.jackson.core,1.9.13
No repository found containing: osgi.bundle,org.codehaus.jackson.mapper,1.9.13

When I do the update, none of the objects to update reference those objects, so I am not sure how it is resolving these to correct it.

While these can be found on Maven that doesn't necessarily help with an update repository. Does anyone know where these can be found in an eclipse repository?

Thanks in advance.
Nathan
Re: Updating software error [message #1768003 is a reply to message #1767848] Wed, 12 July 2017 18:44 Go to previous messageGo to next message
Nathan truhan is currently offline Nathan truhanFriend
Messages: 3
Registered: July 2017
Junior Member
Never mind, found it. It was the Mylyn update site. I have restructured all of them now and was able to update. Spent a while on it and couldn't get it, took overnight to figure it out.
Re: Updating software error [message #1768017 is a reply to message #1768003] Thu, 13 July 2017 00:53 Go to previous messageGo to next message
Jon Olds is currently offline Jon OldsFriend
Messages: 1
Registered: July 2017
Junior Member
how did you solve this?
Re: Updating software error [message #1769282 is a reply to message #1768017] Fri, 28 July 2017 14:26 Go to previous message
Nathan truhan is currently offline Nathan truhanFriend
Messages: 3
Registered: July 2017
Junior Member
Sorry,
I believe it was a matter of using the correct Mylyn update site:
http://download.eclipse.org/mylyn/releases/latest

And also enabling a version of the Orbit repository:
http://download.eclipse.org/tools/orbit/R-builds/R20170516192513/repository

I went to check just a while ago and realized all my repositories got erased somehow, so had to hunt them all down again.

[Updated on: Fri, 28 July 2017 14:28]

Report message to a moderator

Previous Topic:Download or update ?
Next Topic:When I define a new server, I cannot finish, I can only cancel
Goto Forum:
  


Current Time: Sun Feb 23 21:25:26 GMT 2020

Powered by FUDForum. Page generated in 0.11044 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top