Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » "No repository found at" when trying to install plugins from the marketplace
"No repository found at" when trying to install plugins from the marketplace [message #1767580] Fri, 07 July 2017 09:09 Go to next message
Matthijs Wessels is currently offline Matthijs WesselsFriend
Messages: 4
Registered: June 2017
Junior Member
I can't seem to install most plugins from the market place anymore after upgrading to Neon (I don't know what the old Eclipse version was). It used to work on that older version.

I keep getting the following error popup:
No repository found at http://www.pydev.org/updates/.

Some plugins do work.

Work:
- YEdit

Don't work:
- TestNG
- PyDev
- Markdown Text Editor.

If I browse to the repository link with a web browser, I can open the site.

I was able to install TestNG by adding "http://dl.bintray.com/testng-team/testng-eclipse-release/updatesites/:6.10.0.201612030230/" directly as a Software Site in Install New Software. But for most plugins I couldn't find such a url that did work (the repo url always didn't work).

Session Data:
eclipse.buildId=4.6.3.M20170301-0400
java.version=1.8.0_92
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments: -showlocation -product org.eclipse.epp.package.jee.product
Command-line arguments: -os linux -ws gtk -arch x86_64 -showlocation -product org.eclipse.epp.package.jee.product
Re: "No repository found at" when trying to install plugins from the marketplace [message #1767986 is a reply to message #1767580] Wed, 12 July 2017 14:21 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 772
Registered: January 2012
Senior Member

Is there anything in your ...workspace.../.metadata/.log?

Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: "No repository found at" when trying to install plugins from the marketplace [message #1768599 is a reply to message #1767986] Thu, 20 July 2017 12:23 Go to previous message
Matthijs Wessels is currently offline Matthijs WesselsFriend
Messages: 4
Registered: June 2017
Junior Member
I created a new workspace and tried to install the PyDev plugin twice through the market place. This is the result in .metadata/.log

!SESSION 2017-07-20 12:14:52.000 -----------------------------------------------
eclipse.buildId=4.6.3.M20170301-0400
java.version=1.8.0_92
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -showlocation -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os linux -ws gtk -arch x86_64 -showlocation -product org.eclipse.epp.package.jee.product

(...)

!ENTRY org.eclipse.equinox.p2.metadata.repository 4 1000 2017-07-20 12:16:00.430
!MESSAGE No repository found at http://www.pydev.org/updates/.

!ENTRY org.eclipse.equinox.p2.metadata.repository 4 1000 2017-07-20 12:16:04.439
!MESSAGE No repository found at http://www.pydev.org/updates/.

!ENTRY org.eclipse.equinox.p2.metadata.repository 4 1000 2017-07-20 12:16:40.187
!MESSAGE No repository found at http://www.pydev.org/updates/.

!ENTRY org.eclipse.equinox.p2.metadata.repository 4 1000 2017-07-20 12:17:47.906
!MESSAGE No repository found at http://www.pydev.org/updates/.

!ENTRY org.eclipse.equinox.p2.metadata.repository 4 1000 2017-07-20 12:18:03.455
!MESSAGE No repository found at http://www.pydev.org/updates/.
Previous Topic:artifacts.xml documentation?
Next Topic:Install plug-in without resolving dependencies
Goto Forum:
  


Current Time: Tue Sep 18 23:48:16 GMT 2018

Powered by FUDForum. Page generated in 0.02525 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top