Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Oomph setup for Oxygen. Help needed.(Migrating product to Oxygen, latest EMF/Xtext and Java 8)
Oomph setup for Oxygen. Help needed. [message #1767444] Thu, 06 July 2017 07:53 Go to next message
Neeraj Bhusare is currently offline Neeraj BhusareFriend
Messages: 134
Registered: July 2009
Location: Canada
Senior Member
Hi All,

I am working on updating the oomph setup for my product so that we can migrate to Eclipse Oxygen, latest EMF/Xtext and Java 8. During provisioning, I see FileNotFound error for the following plugin's - org.eclipse.emf.compare_3.5.0.201706130827.jar and org.eclipse.emf.query_1.11.0.201706061326.jar.

I understand that these jars should be made available in the artifactory. I got a bit confused after looking at the "emf.compare" download page [0]. It shows version 3.3 as the latest release and the expected version is 3.5. The latest code [2] is at version 3.5 though. Secondly, I downloaded the update site archive of Model Query [1] and found that the contained "emf.query" jar had version 1.7, but the expected version is 1.11.

Am I missing something here ? Any pointers/comments are highly appreciated.

PS : I cannot share the Oomph setup files. I am hoping the details provided above should be sufficient.

[0] https://www.eclipse.org/emf/compare/downloads/
[1] https://www.eclipse.org/modeling/emf/downloads/?showAll=1&hlbuild=R201706061326&project=query#R201706061326
[2] https://github.com/eclipse/emf.compare/blob/master/plugins/org.eclipse.emf.compare/META-INF/MANIFEST.MF

Tx in advance.


Twitter : @NeerajBhusare
Blog : https://nbhusare.github.io/
Best regards, Neeraj
Re: Oomph setup for Oxygen. Help needed. [message #1767462 is a reply to message #1767444] Thu, 06 July 2017 08:59 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29545
Registered: July 2009
Senior Member
I can't really comment on how other projects manage their p2 update sites and their web pages. Often the former are hard to find and/or not documented at all, and the latter are often out-of-date. That's why we provided support for indexing all p2 update sites hosted at Eclipse as well as a way to search that information in the IDE: https://wiki.eclipse.org/Eclipse_Oomph_Authoring#How_to_find_a_P2_repository_at_Eclipse_using_the_Repository_Explorer

Note that both these projects contribute to the release train so their latest release will both be in http://download.eclipse.org/releases/oxygen
Re: Oomph setup for Oxygen. Help needed. [message #1767482 is a reply to message #1767462] Thu, 06 July 2017 10:50 Go to previous message
Neeraj Bhusare is currently offline Neeraj BhusareFriend
Messages: 134
Registered: July 2009
Location: Canada
Senior Member
Thanks for the prompt response.

In the project setup file, I was pointing to the repository http://download.eclipse.org/eclipse/updates/4.7 (took from https://wiki.eclipse.org/Eclipse_Project_Update_Sites). Replacing it with http://download.eclipse.org/releases/oxygen fixed the issue.

Tx for the help.


Twitter : @NeerajBhusare
Blog : https://nbhusare.github.io/
Best regards, Neeraj

[Updated on: Thu, 06 July 2017 10:52]

Report message to a moderator

Previous Topic:get current version number for the product
Next Topic:Custom Oomph binary - Windows signing
Goto Forum:
  


Current Time: Sun Sep 23 01:28:10 GMT 2018

Powered by FUDForum. Page generated in 0.01864 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top