Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » problems in the eclipse installation: failed(failed to install eclipse on debian 8)
problems in the eclipse installation: failed [message #1767259] Tue, 04 July 2017 09:22 Go to next message
pierre mondon is currently offline pierre mondonFriend
Messages: 2
Registered: July 2017
Junior Member
Calculating requirements and dependencies.
Cannot complete the request. Generating details.
ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found.
at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.resolve(ProfileTransactionImpl.java:425)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:337)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:729)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3324)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3252)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3233)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3133)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:567)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:693)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56)
ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1499160008840
ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: artificial_root 1.0.0.v1499160008840 requires 'com.mountainminds.eclemma.feature.feature.group 0.0.0' but it could not be found

Took 29 seconds.
There are failed tasks.
Press Back to choose different settings or Cancel to abort.

here is my problem, i'm on debian 8, 32bits, and i can't understand why i got these problems, maybe there is problems of dependencies... I really don't know, may someone help me please?

thank you for watching
Re: problems in the eclipse installation: failed [message #1767433 is a reply to message #1767259] Thu, 06 July 2017 04:34 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29545
Registered: July 2009
Senior Member
I think you opened https://bugs.eclipse.org/bugs/show_bug.cgi?id=519146 but as I mentioned in that bug, I don't know how to reproduce this problem. None of the Eclipse.org products contain this dependency/requirement.
Re: problems in the eclipse installation: failed [message #1767496 is a reply to message #1767433] Thu, 06 July 2017 13:13 Go to previous message
pierre mondon is currently offline pierre mondonFriend
Messages: 2
Registered: July 2017
Junior Member
it's all right as i said in the bugzilla,
So for the next one who got that bug.
Just delete in the XML file .setup the line of eclema or another dependency, oomph has probably not updated the repository of that one. Then you install it from the market on eclipse.

Thanks for the answer.
Previous Topic:Custom Oomph binary - Windows signing
Next Topic:Unzip folder created by resource copy task
Goto Forum:
  


Current Time: Sat Sep 22 12:39:23 GMT 2018

Powered by FUDForum. Page generated in 0.04662 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top