Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Kura » Why git auth failed?
Why git auth failed? [message #1766673] Sun, 25 June 2017 02:15 Go to next message
LI Yi is currently offline LI YiFriend
Messages: 37
Registered: June 2017
Member
undle org.eclipse.oomph.setup.workingsets 1.7.0.v20170104-1401, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Performing Git Clone git@github.com:eclipse/kura.git (develop)
Cloning Git repo git@github.com:eclipse/kura.git to F:\OpenIOT\Kura\iot-kura-develop3\git\kura
java.lang.Exception: org.eclipse.jgit.api.errors.TransportException: git@github.com:eclipse/kura.git: Auth fail
at org.eclipse.oomph.setup.git.impl.GitCloneTaskImpl.perform(GitCloneTaskImpl.java:882)
Re: Why git auth failed? [message #1767042 is a reply to message #1766673] Thu, 29 June 2017 22:45 Go to previous message
David Woodard is currently offline David WoodardFriend
Messages: 420
Registered: July 2014
Senior Member
Hello,

I believe the git option only works if you have used Eclipse to connect to Github repos in the past. Under "Eclipse Kura Git Repository" , please try one of the HTTPS entries. For example, mine is:

https://dwoodard1@github.com/eclipse/kura.git

Also, it looks like you are on a Windows system. The build will likely not work for Windows. I would recommend setting up a Linux VM if you plan on working with Kura source code.

Thanks,
--Dave
Previous Topic:Publish data to the cloud
Next Topic:Kura GPIO example
Goto Forum:
  


Current Time: Wed Sep 26 07:21:25 GMT 2018

Powered by FUDForum. Page generated in 0.03157 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top