Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Oomph target platform setup(Oomph target platform setup during Oomph authoring)
Oomph target platform setup [message #1766040] Thu, 15 June 2017 05:53 Go to next message
saurabh pathare is currently offline saurabh pathareFriend
Messages: 9
Registered: June 2017
Junior Member
I am new to Oomph installer.I am able to generate eclipse instance and project setup by using Oomph installer for that I am using customize product, project and configuration model in installer.My project has its own .target file and I want to set it as default target platform into installed eclipse.
But every time if I start or restart eclipse it will set Modular target (neon) as default target platform and I have to manually change it to my target file. So please let me know how to set customize .target file as a default target platform in eclipse.
Re: Oomph target platform setup [message #1766046 is a reply to message #1766040] Thu, 15 June 2017 07:54 Go to previous messageGo to next message
Abel Hegedus is currently offline Abel HegedusFriend
Messages: 189
Registered: September 2015
Senior Member
Most probably you have a Targlet task in one of your setups (most likely the project) and have the "Skip automaticic task execution at startup time" preference set to false (default) for Oomph (Window -> Preferences -> Oomph -> Setup Tasks). You can set that to true (and make sure to uncheck the Targlet tasks every time you manually perform setup tasks), but the real solution would be to make sure your setups define what you want to have in your IDE.
Re: Oomph target platform setup [message #1766071 is a reply to message #1766046] Thu, 15 June 2017 12:01 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29650
Registered: July 2009
Senior Member
If you don't want to use targlets and don't have a Targlet task (which you shouldn't if you have a Target Platform task to resolve and set your *.target), be sure to set the eclipse.target.platform variable to the value None which is the default value, but perhaps you have set to Oxygen or Neon.
Re: Oomph target platform setup [message #1766295 is a reply to message #1766046] Tue, 20 June 2017 05:29 Go to previous messageGo to next message
saurabh pathare is currently offline saurabh pathareFriend
Messages: 9
Registered: June 2017
Junior Member
Thanks for your reply Adel......
I tried as per you have mentioned but still it is not working.
Re: Oomph target platform setup [message #1766345 is a reply to message #1766295] Tue, 20 June 2017 12:16 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29650
Registered: July 2009
Senior Member
We can't guess what you've actually done without details. Do you have a Targlet task? Do you have a Target Definition task? Do you have a variable task to set the variable named eclipse.target.platform to the value None?
Re: Oomph target platform setup [message #1766355 is a reply to message #1766071] Tue, 20 June 2017 12:54 Go to previous messageGo to next message
saurabh pathare is currently offline saurabh pathareFriend
Messages: 9
Registered: June 2017
Junior Member
Thanks Ed Merks for your reply.

Actually as per my understanding I am using project.setup file to deal with target platform setup as I want to use my customize .target file.There is a Modular target which contains targlet and repository Neon.So the "eclipse.target.platform" variable's default value is Neon and value is None.I tried to set Mytarget.target value to "eclipse.target.platform" but failed while fetching my project through eclipse updater and giving me an error
"ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found."
I also tried to deactivate "Modular target" and many more things but got the same result.
So please let me know If I am missing something.
Re: Oomph target platform setup [message #1766386 is a reply to message #1766355] Tue, 20 June 2017 20:23 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29650
Registered: July 2009
Senior Member
Delete the Targlet task. Set the eclipse.target.platform to the value None. Create a Target Definition task. Use you *.target name in that task. Test i by creating a new installation and workspace.
Previous Topic:How to disable the Preference Recorder
Next Topic:Oomph root setup and start issues on Linux Mint 18 / Ubuntu 16 LTE
Goto Forum:
  


Current Time: Wed Nov 14 06:41:40 GMT 2018

Powered by FUDForum. Page generated in 0.02131 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top