Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Target doesn't find com.ibm.icu.* bundles
Target doesn't find com.ibm.icu.* bundles [message #1765672] Tue, 13 June 2017 08:53 Go to next message
Vlad Dumitrescu is currently offline Vlad DumitrescuFriend
Messages: 427
Registered: July 2009
Location: Gothenburg
Senior Member
Hi,

I've seen only old questions about similar issues, many without answers. I hope I can get one.

I am running Neon.3 and creating a new target description, where I add the neon udate site and the Platform SDK feature. After p2 does its stuff, I get no errors and set it as active. But the target platform status view shows that most bundles have errors due to not being able to locate com.ibm.icu.text and friends, who aren't in the content of the target platform... Of course, the compiler complains about the same issues.

I tried to add the Orbit update site, and there the ICU feature is shown as already installed and nothing happens.

Does anyone know what is going on? Why aren't the icu bundles accessible? How can I find out more (the logs don't have anything interesting)?

I get an exception sometimes, but I don't think it is related (I am editing the target file with the text editor, otherwise things disappear from it)
java.lang.IllegalStateException: Profile TARGET_DEFINITION:resource:/shade/neon.target is not current. Expected timestamp 1497341797961 but was 1497341795637.


Looking at the downloaded bundles, even others are missing, like org.eclipse.help.ui.

best regards,
Vlad
Re: Target doesn't find com.ibm.icu.* bundles [message #1765676 is a reply to message #1765672] Tue, 13 June 2017 08:58 Go to previous message
Vlad Dumitrescu is currently offline Vlad DumitrescuFriend
Messages: 427
Registered: July 2009
Location: Gothenburg
Senior Member
Perhaps an important clue: trying the same thing with Mars as the target, it works fine. So is the neon update site incomplete, or what?


Previous Topic:error while installing spring tool suite for eclipse 4.6
Next Topic:Build tab
Goto Forum:
  


Current Time: Thu Nov 15 07:08:31 GMT 2018

Powered by FUDForum. Page generated in 0.02892 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top