Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP Supplemental repos not supported by Tycho 1.0
RAP Supplemental repos not supported by Tycho 1.0 [message #1765099] Tue, 06 June 2017 14:36 Go to next message
Wim Jongman is currently offline Wim JongmanFriend
Messages: 432
Registered: July 2009
Senior Member

Hi,

At Nebula we build with a RAP supplemental repo but it does not want to build with Tycho 1.0.0. It seems the repos are too old and need to be rebuild.

http://download.eclipse.org/rt/rap/incubator/2.0/fileupload/
http://download.eclipse.org/rt/rap/incubator/2.3/fileupload/

Error message from Tycho:

[ERROR] 1 error: org/eclipse/tycho/core/p2/P2ArtifactRepositoryLayout : Unsupported major.minor version 52.0
Re: RAP Supplemental repos not supported by Tycho 1.0 [message #1765470 is a reply to message #1765099] Fri, 09 June 2017 22:46 Go to previous messageGo to next message
Chris Fairhall is currently offline Chris FairhallFriend
Messages: 206
Registered: February 2011
Senior Member
Sounds to me like the JVM you're using is too old. class version 52 requires Java 8 or later
Re: RAP Supplemental repos not supported by Tycho 1.0 [message #1765537 is a reply to message #1765470] Mon, 12 June 2017 09:23 Go to previous messageGo to next message
Wim Jongman is currently offline Wim JongmanFriend
Messages: 432
Registered: July 2009
Senior Member

Thanks. I though maybe the repos were too old.
Re: RAP Supplemental repos not supported by Tycho 1.0 [message #1765654 is a reply to message #1765537] Tue, 13 June 2017 07:44 Go to previous messageGo to next message
Markus Knauer is currently offline Markus KnauerFriend
Messages: 147
Registered: July 2009
Senior Member

Hi Wim,

speaking about "too old"...

The two important bundles from this repository have been migrated to the main RAP Runtime project for quite some time as org.eclipse.rap.filedialog and org.eclipse.rap.fileupload. Wouldn't it make sense to migrate, too, or are there any reasons not to switch?

In that case you could use the Oxygen Release Repository for RAP 3.2 at http://download.eclipse.org/rt/rap/3.2 (soon to be released), or the older Neon Release Repository with RAP 3.1.

(And as an additional plus, while not related, the RAP 3.2 repo is being built with Tycho 1.0).

Regards,
Markus


--

Twitter: @mknauer23 and @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: RAP Supplemental repos not supported by Tycho 1.0 [message #1765663 is a reply to message #1765654] Tue, 13 June 2017 08:26 Go to previous messageGo to next message
Wim Jongman is currently offline Wim JongmanFriend
Messages: 432
Registered: July 2009
Senior Member

Hi Markus,

I have been looking for a new place to consume the fileupload bundle but I could not find it. I had to switch back to Tycho 0.24.0.

Thank you for that pointer, now I can fix the build.

Cheers,

Wim
Re: RAP Supplemental repos not supported by Tycho 1.0 [message #1765673 is a reply to message #1765663] Tue, 13 June 2017 08:54 Go to previous messageGo to next message
Wim Jongman is currently offline Wim JongmanFriend
Messages: 432
Registered: July 2009
Senior Member

I have upgraded to the repo that you indicated but I get errors:

[ERROR] Software being installed: org.eclipse.nebula.widgets.picture 1.0.0.qualifier
[ERROR] Missing requirement: org.eclipse.nebula.widgets.picture 1.0.0.qualifier requires 'bundle org.eclipse.rap.rwt.supplemental.filedialog 0.0.0' but it could not be found

Thank you,

Wim
Re: RAP Supplemental repos not supported by Tycho 1.0 [message #1765674 is a reply to message #1765673] Tue, 13 June 2017 08:58 Go to previous messageGo to next message
Markus Knauer is currently offline Markus KnauerFriend
Messages: 147
Registered: July 2009
Senior Member

Part of the migration to the main RAP Runtime project was the change of the bundle symbolic name. Depending on how you define your dependencies, this needs to be updated, too

- org.eclipse.rap.filedialog
- org.eclipse.rap.fileupload

As far as I remember (it's long ago...) the internal structure, i.e. the exported packages, didn't change.

Does that help to resolve your issues?

Regards,
Markus
Re: RAP Supplemental repos not supported by Tycho 1.0 [message #1765677 is a reply to message #1765673] Tue, 13 June 2017 09:06 Go to previous message
Wim Jongman is currently offline Wim JongmanFriend
Messages: 432
Registered: July 2009
Senior Member

It did. Thanks!
Previous Topic:How to set BusinessTheme programatically?
Next Topic:Is it legal to call RemoteObject.call() inside setTimeout()
Goto Forum:
  


Current Time: Mon Oct 22 01:31:13 GMT 2018

Powered by FUDForum. Page generated in 0.03876 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top