Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Problems setting up Linux RCP APP with existing code from Windows eclipse platform
Problems setting up Linux RCP APP with existing code from Windows eclipse platform [message #1764830] Fri, 02 June 2017 14:04 Go to next message
Khady Seck is currently offline Khady SeckFriend
Messages: 1
Registered: June 2017
Junior Member
Hello,

We are trying to create a Linux development system to support future Linux specific bugs for our RCP app. We have a fully working RCP app created from eclipse on a WIndows machine. Taking the code as is and downloading it on the Linux eclipse development environment we see different runtime issues with SWT which I understand is platform specific.

I changed the e4.target file environment tab to OS: linux and windowing system: gtk
(See image Selection_004.png below)

In the .product file Dependencies tab I deleted the mentions of org.eclipse.*.win32 and did not replace them no clue what i need to do for that. I just clicked Add required plugins and nothing was added. (Image Selection_006.png)

Finally in the Configuration and Launching tabs of the .product I chose linux as execuion environment and program launcher (Image Selection_005.png).


Thanks in advance for the help.
Re: Problems setting up Linux RCP APP with existing code from Windows eclipse platform [message #1764997 is a reply to message #1764830] Mon, 05 June 2017 15:54 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 788
Registered: January 2012
Senior Member

So what problems are you seeing?

Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Previous Topic:Please help: Need to clean osgi cache
Next Topic:Popup menu doesn't synch with E4 model
Goto Forum:
  


Current Time: Mon Nov 19 17:34:34 GMT 2018

Powered by FUDForum. Page generated in 0.02406 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top