Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Papyrus for Real Time » Installing PapyrusRT using update site fails(Installing PapyrusRT using update site fails)
Installing PapyrusRT using update site fails [message #1764624] Wed, 31 May 2017 21:59 Go to next message
Mojtaba Bagherzadeh is currently offline Mojtaba BagherzadehFriend
Messages: 32
Registered: April 2016
Member
Hi,
Installing the PapyrusRT using the update site "http://download.eclipse.org/papyrus-rt/updates/releases/neon/0.9.0/"
fails with the following error:

index.php/fa/29512/0/

Any suggestion to fix that?

Thanks
Mojtaba
Re: Installing PapyrusRT using update site fails [message #1764705 is a reply to message #1764624] Thu, 01 June 2017 13:48 Go to previous messageGo to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 350
Registered: March 2011
Senior Member
Hi. That's to be expected. The update site doesn't bundle Papyrus-RT's dependencies, such as Papyrus Designer (as it appears in the error message).

As the website mentions, using the update site to install Papyrus-RT is for those who want full control of the installation, but is more complex. As with any Eclipse product, using the update sites manually often means that you have to manually add update sites for the dependencies and install them yourself. For this reason it is preferable to use either the RCP or the Papyrus-RT installer. If you want to update an existing installation, you can use Help->Check for updates on a Papyrus-RT installed with the RCP or the installer. But there are no publicly released updates to 0.9.0 yet. The next update will be 1.0.

Are you trying to install a user version of Papyrus-RT or a developer version? Do you want the nightly updates on a user version?
Re: Installing PapyrusRT using update site fails [message #1764735 is a reply to message #1764705] Thu, 01 June 2017 20:51 Go to previous message
Mojtaba Bagherzadeh is currently offline Mojtaba BagherzadehFriend
Messages: 32
Registered: April 2016
Member
Hi, Thanks for the reply.
I was trying to install the user version. I needed to use update site because I had an installed Eclipse and I did not want to install a separate Eclipse for PapyrusRT.
Anyway, thanks for the hint, I installed the Papyrus Designer and EMFCompare using the following update sites. After that, I was able to install the PapyrusRT using update site.

Papyrus Designer update site: "http://download.eclipse.org/modeling/mdt/papyrus/components/designer/"
EMFCompare update site : "http://download.eclipse.org/modeling/emf/compare/updates/releases/latest"

It would be great if you mention the requirement for dependencies in the PapyrusRT download page:
https://eclipse.org/papyrus-rt/content/download.php#UpdateSites

Thanks
Mojtaba





Previous Topic:rtBound signal is not shown in message list
Next Topic:Removing gradient style in the diagrams (no background shading)
Goto Forum:
  


Current Time: Thu Sep 20 18:02:59 GMT 2018

Powered by FUDForum. Page generated in 0.01579 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top