Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mosquitto » OpenSSL error....can't figure it out(OpenSSL issue)
OpenSSL error....can't figure it out [message #1763524] Wed, 17 May 2017 04:37
Steven DAmbra is currently offline Steven DAmbraFriend
Messages: 1
Registered: May 2017
Junior Member
I'm running into an issue and i simply can't figure it out. going on two weeks now!
Installed the latest version of Mosquitto and Openssl on a server 2012 instance. Works fine, but now trying to enable TLS. I cannot get a purchased nor self signed certificate to work. I've read the manual, i followed a tutorial listed(can't list the link as its blocked), neither works.

Steps i've taken:
I placed the certificates into a folder and set the following values:
cafile C:\mosquitto\certs\ca.crt
certfile C:\mosquitto\certs\server.crt
keyfile C:\mosquitto\certs\server.key
Changed the port from 1883 to 8883.
restarted Mosquitto. It starts up without issue.

Everytime i try to connect from a client, i get the following message:
OpenSSL Error: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown
OpenSSL Error: error:140940E5:SSL routines:ssl3_read_bytes:ssl handshake failure

i re imported this certificate about 50 times now. i've tried every option possible. I've tried using .pem instead of .crt.
Does anyone have any idea???
Previous Topic:Mosquitto using ram log files
Next Topic:Possible to get list of topics subscribed ?
Goto Forum:
  


Current Time: Thu Sep 20 11:24:23 GMT 2018

Powered by FUDForum. Page generated in 0.01664 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top