Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » JDTCompilerAdapter invalid dependency(Ant build project error: JDTCompilerAdapter invalid dependency)
JDTCompilerAdapter invalid dependency [message #1760323] Tue, 25 April 2017 19:21
Shaun Upjohn is currently offline Shaun UpjohnFriend
Messages: 4
Registered: April 2017
Junior Member
I have an ant build project that I need to use JDTCompilerAdapter with

I have the following target added. And I have tried putting ecj4.6.1.jar in the ant library as well as another time putting jdtCompilerAdapter.jar and org.eclipse.jdt.core_3.12.3.v20170228-1205.jar in the lib folder.

I am getting the error Class org.eclipse.jdt.core.JDTCompilerAdapter could not be loaded because of an invalid dependency.

<target description="compile project with Eclipse compiler" name="build-eclipse-compiler">
        <property name="build.compiler" value="org.eclipse.jdt.core.JDTCompilerAdapter"/>

Thanks for all the thoughts and assistance.
Previous Topic:Creating a plugin with refactorings
Next Topic:Read and Writes From A .txt file to a 2-d array
Goto Forum:

Current Time: Sat Mar 17 06:34:35 GMT 2018

Powered by FUDForum. Page generated in 0.01786 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software