Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Papyrus for Real Time » Error while performing start-up tasks(Error : Papyrus-RT Developers guide installation )
Error while performing start-up tasks [message #1760148] Sun, 23 April 2017 20:21 Go to next message
Sudharshan Gopikrishnan is currently offline Sudharshan GopikrishnanFriend
Messages: 15
Registered: April 2017
Junior Member
Hello all,

I had recently downloaded the, Papyrus-RT developers version (Link: https://wiki.eclipse.org/Papyrus-RT/Developer/Developer_Guide/DevEnv_Neon). I followed the installation instructions as suggested in the tutorial. But after the installation and while performing the start-up tasks, I get the following error. None of the Java packages are detected nor any Java commands. I was earlier working with the Neon-2 version of the same, and I did not encounter any such error. I started getting the error when I upgraded to Neon 3 version and higher. I am not sure what the issue is. Has anyone encountered such an error before? Any assistance you provide will be of tremendous help.

Also, attached few screenshots of the error.

Thank You.

Executing manual tasks
Java(TM) SE Runtime Environment 1.8.0_101-b13
Product org.eclipse.products.epp.package.committers.latest.released
Project org.eclipse.papyrus-rt.master
Project org.eclipse.papyrus-rt.profile.master
Project org.eclipse.papyrus-rt.common.master
Project org.eclipse.papyrus-rt.core.master
Project org.eclipse.papyrus-rt.tooling.master
Project org.eclipse.papyrus-rt.compare.master
Project org.eclipse.papyrus-rt.codegen.master
Project org.eclipse.papyrus-rt.xtumlrt.master
Project org.eclipse.papyrus-rt.cpp.master
Project org.eclipse.papyrus-rt.migration.master
Project org.eclipse.papyrus-rt.releng.master
Project org.eclipse.papyrus-rt.mylyn.master
Project org.eclipse.papyrus-rt.Oomph.master
Project org.eclipse.papyrus-rt.installer.master
Bundle org.eclipse.oomph.setup 1.7.0.v20170224-1311, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Bundle org.eclipse.oomph.setup.core 1.7.0.v20170301-0747, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Bundle org.eclipse.oomph.setup.git 1.7.0.v20170104-1401, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Bundle org.eclipse.oomph.setup.jdt 1.7.0.v20170305-1123, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Bundle org.eclipse.oomph.setup.launching 1.7.0.v20170104-1401, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Bundle org.eclipse.oomph.setup.mylyn 1.7.0.v20170104-1401, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Bundle org.eclipse.oomph.setup.p2 1.7.0.v20170217-1051, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Bundle org.eclipse.oomph.setup.pde 1.7.0.v20170201-1645, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Bundle org.eclipse.oomph.setup.projects 1.7.0.v20170104-1401, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Bundle org.eclipse.oomph.setup.targlets 1.7.0.v20170201-1645, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Bundle org.eclipse.oomph.setup.workingsets 1.7.0.v20170104-1401, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
Performing P2 Director (Eclipse IDE for Eclipse Committers (Neon) + Papyrus-RT Tools + Core Development Tools + Code Quality Tools + Maven Connectors for m2e + Eclipse IDE for Eclipse Committers (Neon) + Papyrus-RT Tools + Core Development Tools + Code Quality Tools + Maven Connectors for m2e + Codegen Developer Tools + Eclipse IDE for Eclipse Committers (Neon) + Papyrus-RT Tools + Core Development Tools + Code Quality Tools + Maven Connectors for m2e + XtUML-RT Developer Tools + Eclipse IDE for Eclipse Committers (Neon) + Papyrus-RT Tools + Core Development Tools + Code Quality Tools + Maven Connectors for m2e + Model Migration Developer Tools + Eclipse IDE for Eclipse Committers (Neon) + Papyrus-RT Tools + Core Development Tools + Code Quality Tools + Maven Connectors for m2e + Mylyn Tools)
Offline = false
Mirrors = true
Resolving 71 requirements from 12 repositories to C:\Users\VGHR\papyrus-rt-master\eclipse
Requirement org.sonatype.m2e.buildhelper.feature.feature.group
Requirement org.sonatype.tycho.m2e.feature.feature.group
Requirement com.mountainminds.eclemma.feature.feature.group (optional)
Requirement net.sf.eclipsecs.feature.group (optional)
Requirement edu.umd.cs.findbugs.plugin.eclipse.feature.group (optional)
Requirement org.eclipse.emf.sdk.feature.group
Requirement org.eclipse.uml2.sdk.feature.group
Requirement org.eclipse.pde.api.tools.ee.feature.feature.group
Requirement org.eclipse.egit.feature.group
Requirement org.eclipse.m2e.feature.feature.group
Requirement org.eclipse.papyrusrt.feature.feature.group
Requirement org.eclipse.papyrus.sdk.feature.feature.group
Requirement org.eclipse.papyrus.extra.dsml.validation.feature.feature.group
Requirement epp.package.committers [4.6.0,4.7.0)
Requirement org.eclipse.platform.feature.group [4.6.0,4.7.0)
Requirement org.eclipse.rcp.feature.group [4.6.0,4.7.0)
Requirement org.eclipse.buildship.feature.group
Requirement org.eclipse.cvs.feature.group
Requirement org.eclipse.cvs.source.feature.group
Requirement org.eclipse.e4.core.tools.feature.feature.group
Requirement org.eclipse.egit.mylyn.feature.group
Requirement org.eclipse.epp.package.common.feature.feature.group
Requirement org.eclipse.equinox.p2.user.ui.feature.group
Requirement org.eclipse.help.feature.group
Requirement org.eclipse.jdt.feature.group
Requirement org.eclipse.jdt.source.feature.group
Requirement org.eclipse.jgit.feature.group
Requirement org.eclipse.jgit.http.apache.feature.group
Requirement org.eclipse.mylyn.bugzilla_feature.feature.group
Requirement org.eclipse.mylyn.builds.feature.group
Requirement org.eclipse.mylyn.commons.feature.group
Requirement org.eclipse.mylyn.commons.identity.feature.group
Requirement org.eclipse.mylyn.commons.notifications.feature.group
Requirement org.eclipse.mylyn.commons.repositories.feature.group
Requirement org.eclipse.mylyn.commons.repositories.http.feature.group
Requirement org.eclipse.mylyn.discovery.feature.group
Requirement org.eclipse.mylyn.gerrit.dashboard.feature.feature.group
Requirement org.eclipse.mylyn.gerrit.feature.feature.group
Requirement org.eclipse.mylyn.git.feature.group
Requirement org.eclipse.mylyn.hudson.feature.group
Requirement org.eclipse.mylyn.monitor.feature.group
Requirement org.eclipse.mylyn.reviews.feature.feature.group
Requirement org.eclipse.mylyn.team_feature.feature.group
Requirement org.eclipse.mylyn.versions.feature.group
Requirement org.eclipse.mylyn.wikitext_feature.feature.group
Requirement org.eclipse.mylyn_feature.feature.group
Requirement org.eclipse.pde.feature.group
Requirement org.eclipse.pde.source.feature.group
Requirement org.eclipse.platform.source.feature.group
Requirement org.eclipse.rcp.source.feature.group
Requirement org.eclipse.recommenders.mylyn.rcp.feature.feature.group
Requirement org.eclipse.recommenders.news.rcp.feature.feature.group
Requirement org.eclipse.recommenders.rcp.feature.feature.group
Requirement org.eclipse.recommenders.snipmatch.rcp.feature.feature.group
Requirement org.eclipse.oomph.setup.feature.group
Requirement org.eclipse.oomph.targlets.feature.group
Requirement org.eclipse.oomph.setup.targlets.feature.group
Requirement org.eclipse.oomph.setup.pde.feature.group
Requirement org.eclipse.oomph.setup.git.feature.group
Requirement org.eclipse.oomph.setup.projects.feature.group
Requirement org.eclipse.oomph.setup.workingsets.feature.group
Requirement org.eclipse.mylyn.ide_feature.feature.group
Requirement org.eclipse.mylyn.java_feature.feature.group
Requirement org.eclipse.mylyn.pde_feature.feature.group
Requirement org.eclipse.oomph.setup.mylyn.feature.group
Requirement org.eclipse.mylyn.tasks.core
Requirement org.eclipse.mylyn.tasks.ui
Requirement org.eclipse.m2m.qvt.oml.sdk.feature.group
Requirement org.eclipse.xtext.sdk.feature.group
Requirement org.eclipse.oomph.setup.launching.feature.group
Requirement org.eclipse.oomph.setup.jdt.feature.group
Repository http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-buildhelper/0.15.0/N/0.15.0.201207090124/
Repository http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-tycho/0.8.0/N/LATEST/
Repository http://update.eclemma.org/
Repository http://eclipse-cs.sf.net/update/
Repository http://findbugs.cs.umd.edu/eclipse/
Repository http://download.eclipse.org/technology/epp/packages/neon
Repository http://download.eclipse.org/releases/neon/201703231000
Repository http://download.eclipse.org/oomph/updates/milestone/latest
Repository http://download.eclipse.org/egit/updates
Repository http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/
Repository http://download.eclipse.org/papyrus-rt/updates/nightly/neon/
Repository http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/neon/
Adding repository http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-tycho/0.8.0/N/LATEST/
Adding repository http://update.eclemma.org/
Adding repository http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-buildhelper/0.15.0/N/0.15.0.201207090124/
Adding repository http://eclipse-cs.sf.net/update/
Adding repository http://download.eclipse.org/releases/neon/201703231000
Adding repository http://download.eclipse.org/technology/epp/packages/neon
Adding repository http://download.eclipse.org/egit/updates
Adding repository http://findbugs.cs.umd.edu/eclipse/
Adding repository http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/
Adding repository http://download.eclipse.org/oomph/updates/milestone/latest
Adding repository http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/neon/
Adding repository http://download.eclipse.org/papyrus-rt/updates/nightly/neon/
Searching for markers
Process resource updates
Searching for markers
Process resource updates
Calculating requirements and dependencies.
Computing prerequisite plan
No software updates are available
Performing Targlets Modular Target (C++ Dependencies + Core Dependencies + Eclipse Platform + Papyrus-RT Codegen Dependencies + Papyrus-RT Codegen and Runtime Plug-ins + Papyrus-RT Dependencies + Papyrus-RT Installer Dependencies + Papyrus-RT Main Plug-ins + Papyrus-RT Tooling Test Dependencies + UML-RT Migration Dependencies + XtUML-RT Dependencies), activate
Repository http://download.eclipse.org/eclipse/updates/4.6
Repository http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/neon/main/
Repository http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/neon/extra/
Repository http://download.eclipse.org/tools/cdt/builds/neon/milestones/
Repository http://download.eclipse.org/modeling/tmf/xtext/updates/composite/milestones/
Repository http://download.eclipse.org/tools/cdt/launchbar/neon.1/
Repository http://download.eclipse.org/tools/orbit/downloads/drops/R20160221192158/repository/
Repository http://download.eclipse.org/releases/neon/
Repository http://download.eclipse.org/modeling/mdt/papyrus/components/designer/
Repository http://download.eclipse.org/modeling/emf/compare/updates/logical/emf.compare/nightly/latest
Repository http://download.eclipse.org/egit/updates
Repository https://hudson.eclipse.org/papyrus/job/Papyrus-Neon-Developer/lastSuccessfulBuild/artifact/repository
Repository http://download.eclipse.org/elk/updates/releases/0.1.0/
Repository http://download.eclipse.org/oomph/products/latest/repository/
Repository http://download.eclipse.org/papyrus-rt/updates/nightly/neon/
Offline = false
Mirrors = true
Adding repository http://download.eclipse.org/eclipse/updates/4.6
Adding repository http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/neon/extra/
Adding repository http://download.eclipse.org/tools/cdt/builds/neon/milestones/
Adding repository http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/neon/main/
Adding repository http://download.eclipse.org/modeling/tmf/xtext/updates/composite/milestones/
Adding repository http://download.eclipse.org/tools/cdt/launchbar/neon.1/
Adding repository http://download.eclipse.org/tools/orbit/downloads/drops/R20160221192158/repository/
Adding repository http://download.eclipse.org/releases/neon/
Adding repository http://download.eclipse.org/modeling/mdt/papyrus/components/designer/
Adding repository http://download.eclipse.org/modeling/emf/compare/updates/logical/emf.compare/nightly/latest
Adding repository http://download.eclipse.org/papyrus-rt/updates/nightly/neon/
Adding repository http://download.eclipse.org/oomph/products/latest/repository/
Adding repository http://download.eclipse.org/elk/updates/releases/0.1.0/
Adding repository https://hudson.eclipse.org/papyrus/job/Papyrus-Neon-Developer/lastSuccessfulBuild/artifact/repository
Adding repository http://download.eclipse.org/egit/updates
Updating Git status for repository org.eclipse.papyrus-rt
Updating Git status for repository org.eclipse.papyrus-rt: 1% ( 114/5792)
Calculating requirements and dependencies.
Cannot complete the request. Generating details.
ERROR: org.eclipse.equinox.p2.director code=10054 Cannot complete the install because of a conflicting dependency.
at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:820)
at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl$4.run(TargletTaskImpl.java:1128)
at org.eclipse.oomph.util.pde.TargetPlatformUtil.runWithTargetPlatformService(TargetPlatformUtil.java:120)
at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:1036)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3324)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:3267)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4488)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4482)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4480)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3258)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3233)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3133)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:567)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:693)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1492977356333
ERROR: org.eclipse.equinox.p2.director code=1 Only one of the following can be installed at once:
ERROR: org.eclipse.equinox.p2.director code=0 Eclipse Workbench Model 1.2.0.v20160229-1459 (org.eclipse.e4.ui.model.workbench 1.2.0.v20160229-1459)
ERROR: org.eclipse.equinox.p2.director code=0 Eclipse Workbench Model 2.0.0.v20170228-1842 (org.eclipse.e4.ui.model.workbench 2.0.0.v20170228-1842)
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1492977356333
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.oomph.setup.installer.feature.group 0.0.0
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1492977356333
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.papyrus.junit.utils 0.0.0
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse 4 Rich Client Platform 1.6.0.v20170422-1905 (org.eclipse.e4.rcp.feature.group 1.6.0.v20170422-1905)
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.e4.ui.model.workbench [2.0.0.v20170228-1842]
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: Oomph Setup Installer 1.8.0.v20170422-2000 (org.eclipse.oomph.setup.installer.feature.group 1.8.0.v20170422-2000)
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.rcp.feature.group [4.7.0.v20170422-2000]
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: Utils classes for JUnit tests 2.0.1.201704230245 (org.eclipse.papyrus.junit.utils 2.0.1.201704230245)
ERROR: org.eclipse.equinox.p2.director code=0 To: bundle org.eclipse.e4.ui.model.workbench [1.2.0,2.0.0)
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse RCP 4.7.0.v20170422-2000 (org.eclipse.rcp.feature.group 4.7.0.v20170422-2000)
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.e4.rcp.feature.group [1.6.0.v20170422-1905]

Took 37 seconds.
There are failed tasks.
Press Back to choose different settings or Cancel to abort.
Touching resource '/org.eclipse.papyrusrt.xtumlrt.xtext'.

Re: Error while performing start-up tasks [message #1760150 is a reply to message #1760148] Sun, 23 April 2017 21:58 Go to previous messageGo to next message
Christian W. Damus is currently offline Christian W. DamusFriend
Messages: 1176
Registered: July 2009
Location: Canada
Senior Member

Hi,

You don't need to set up the Installer sub-project in order to work on the Papyrus-RT code. It is not a part of the product and Oomph has already moved on to the Oxygen platform. Just run the setup without selecting the Installer sub-project for import.

HTH,

Christian
Re: Error while performing start-up tasks [message #1760155 is a reply to message #1760150] Mon, 24 April 2017 04:10 Go to previous messageGo to next message
Sudharshan Gopikrishnan is currently offline Sudharshan GopikrishnanFriend
Messages: 15
Registered: April 2017
Junior Member
Hello Christian,

Thank you for your reply. I tried following your approach and didn't choose the installer-sub project, but I still get the error (Screenshot 1). I am new to Papyrus-RT, so sorry for any inconvenience caused. It would be really great, if you could help me out with this error.

Thank You.

Regards,
Sudharshan
Re: Error while performing start-up tasks [message #1760200 is a reply to message #1760155] Mon, 24 April 2017 14:08 Go to previous messageGo to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 361
Registered: March 2011
Senior Member
This is odd. I cannot reproduce the error. This is in fact different than the original error, since it says that it is trying to install both UML 5.2 and UML 5.3. Did you select any other project (such as Papyrus itself)? That may be the source of the problem.

Also, just to be sure, the "Developer" installation is for people who want to extend Papyrus-RT, as opposed to just use Papyrus-RT.

PS: Due to some problems with Oomph, once the process finishes, you may still have compile errors in the workspace. To solve them, simply go to "Help->Perform Setup Tasks...", follow the instructions, and in the "Eclipse Updater/Confirmation" dialog, un-select the first two tasks "P2 Director" and "Modular Target", and click [Finish].


Re: Error while performing start-up tasks [message #1760316 is a reply to message #1760200] Tue, 25 April 2017 18:46 Go to previous messageGo to next message
Sudharshan Gopikrishnan is currently offline Sudharshan GopikrishnanFriend
Messages: 15
Registered: April 2017
Junior Member
Hello Ernesto,

Thank you for your reply. So I tried, re-installing Papyrus-RT developers version by following the tutorial. I selected only the Papyrus-RT package (including all the sub projects within it). No other packages were selected.

And as suggested, I un-selected the first two tasks and performed the set-up tasks once more. After this, I cleaned all the projects, but I still get compilation errors. Would you happen to know the reason?

Also, while performing the set-up tasks, I observed the following error in the console window, but the set-up tasks completed without any issues and the build was successful.

"Error: Could not find or load main class org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher"

I have attached few screenshots for your reference. If you know something about the issue it would be of great help.

Thank You for your time.

Regards,
Sudharshan



Re: Error while performing start-up tasks [message #1760317 is a reply to message #1760316] Tue, 25 April 2017 19:04 Go to previous messageGo to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 361
Registered: March 2011
Senior Member
It's not clear from your latest comment whether you are doing this by running the Eclipse installer again, or doing "Help->Perform Setup Tasks...".

Executing the Eclipse Installer will install a new, fresh workbench. Doing Help->Perform Setup Tasks... will update an existing installation.

If you already have a existing Papyrus-RT developer environment, try doing Help->Perform Setup Tasks... again, but this time select all tasks, including the P2 Director and the Modular Target.

If this doesn't work, try executing the process from the beginning with the Eclipse Installer, as described in [1] (I've updated the instructions). When doing that, make sure that under "Product Version" you select "Neon", not "Oxygen" or "Mars". Under Projects, select only Papyrus-RT and its subcomponents, *except* for the "Installer" component. Note that running the Eclipse Installer again will create a new, separate installation in a separate folder.

[1] https://wiki.eclipse.org/Papyrus-RT/Developer/Developer_Guide/DevEnv_Neon
Re: Error while performing start-up tasks [message #1760334 is a reply to message #1760317] Wed, 26 April 2017 03:33 Go to previous messageGo to next message
Sudharshan Gopikrishnan is currently offline Sudharshan GopikrishnanFriend
Messages: 15
Registered: April 2017
Junior Member
Hello Ernesto,

Thank you for the detailed instructions in the Wiki Papyrus-RT site.
I re-installed the software, following all the installation instructions as is from website.
Almost, all the errors were gone, except for a couple of errors in the Papyrus-RT XtUML-RT package (Screenshots attached).

I also ran the set-up tasks from the help option and cleaned up all the projects. The errors still persists. It would be really helpful if you could provide any solution for these errors.

Thank you.

Regards,
Sudharshan
  • Attachment: 1.png
    (Size: 231.98KB, Downloaded 80 times)
  • Attachment: 2.png
    (Size: 209.85KB, Downloaded 69 times)
  • Attachment: 3.png
    (Size: 201.10KB, Downloaded 65 times)
  • Attachment: 4.png
    (Size: 207.20KB, Downloaded 71 times)
Re: Error while performing start-up tasks [message #1760375 is a reply to message #1760334] Wed, 26 April 2017 13:48 Go to previous messageGo to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 361
Registered: March 2011
Senior Member
Can you open the "Problems" view, copy all the errors and post them here? (for readability, it's better if you copy and paste the errors, rather than attaching a screenshot).
Re: Error while performing start-up tasks [message #1760690 is a reply to message #1760375] Mon, 01 May 2017 22:18 Go to previous messageGo to next message
Sudharshan Gopikrishnan is currently offline Sudharshan GopikrishnanFriend
Messages: 15
Registered: April 2017
Junior Member
Hello Ernesto,

I was able to resolve all the errors. Thank you for your immense help !

Regards,
Sudharshan
Re: Error while performing start-up tasks [message #1760691 is a reply to message #1760690] Mon, 01 May 2017 23:12 Go to previous messageGo to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 361
Registered: March 2011
Senior Member
Can you post what were the errors and how did you resolve them so that other users can benefit from your solution?

Thanks.
Re: Error while performing start-up tasks [message #1781437 is a reply to message #1760691] Wed, 07 February 2018 10:47 Go to previous messageGo to next message
Dmitrii Nikeshkin is currently offline Dmitrii NikeshkinFriend
Messages: 28
Registered: February 2018
Junior Member
Hello,

During installation using https://wiki.eclipse.org/Papyrus-RT/Developer/Developer_Guide/DevEnv tutorial I get the following error:
Adding repository https://hudson.eclipse.org/papyrus/job/Papyrus-Master-Developer/lastSuccessfulBuild/artifact/repository
Adding repository http://download.eclipse.org/egit/updates-stable-nightly/
Calculating requirements and dependencies.
Cannot complete the request.  Generating details.
ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found.
  at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:825)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl$4.run(TargletTaskImpl.java:1128)
  at org.eclipse.oomph.util.pde.TargetPlatformUtil.runWithTargetPlatformService(TargetPlatformUtil.java:120)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:1036)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3324)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:3267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4494)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4488)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4486)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3258)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3233)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3133)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:575)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:701)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56)
  ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1518000326231
  ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: Utils classes for JUnit tests 2.1.100.201802070352 (org.eclipse.papyrus.junit.utils 2.1.100.201802070352) requires 'bundle org.eclipse.papyrus.uml.tools [4.0.0,5.0.0)' but it could not be found
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1518000326231
    ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.papyrus.junit.utils 0.0.0

Took 41 seconds.
There are failed tasks.
Press Back to choose different settings or Cancel to abort.


Any suggestions how to solve it? Thanks!
Re: Error while performing start-up tasks [message #1781729 is a reply to message #1781437] Mon, 12 February 2018 15:59 Go to previous message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 361
Registered: March 2011
Senior Member
Hi. First, just to confirm, you want the *developer* environment, not the user-environment, correct?

If you want the developer environment, unfortunately at this moment the Oomph setup model is broken because of some issues related to the target platform and its dependencies to the base Papyrus.

We are trying to fix them but we don't know when it will be fixed.

In the meantime, I'm trying to write down instructions on setting up the environment manually, but it is not easy, and it will take some time.

But I'll post a note here when the instructions are available in the wiki.

Previous Topic:log levels?
Next Topic:Protocol function (operation) input parameter type issue
Goto Forum:
  


Current Time: Sun Nov 18 06:12:13 GMT 2018

Powered by FUDForum. Page generated in 0.02841 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top